Foxit Reader和Foxit PhantomPDF 竞争条件问题漏洞

CVE编号

CVE-2018-20314

利用情况

暂无

补丁情况

N/A

披露时间

2021-01-08
漏洞描述
Foxit Reader和Foxit PhantomPDF都是中国福昕(Foxit)公司的一款PDF文档阅读器。

Foxit Reader和PhantomPDF存在安全漏洞。攻击者可利用漏洞导致堆栈缓冲区溢出或越位读取。
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://www.foxitsoftware.com/support/security-bulletins.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 foxitsoftware phantompdf * Up to
(excluding)
8.3.10
运行在以下环境
应用 foxitsoftware phantompdf * From
(including)
9.0
Up to
(excluding)
9.5
运行在以下环境
应用 foxitsoftware reader * Up to
(excluding)
9.5
CVSS3评分
8.1
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-125 跨界内存读
CWE-362 使用共享资源的并发执行不恰当同步问题(竞争条件)
CWE-787 跨界内存写
阿里云安全产品覆盖情况