低危 scp客户端不正确的目录名称验证

CVE编号

CVE-2018-20685

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-01-11
漏洞描述
在OpenSSH 7.9中,scp客户端中的scp.c允许远程SSH服务器通过文件名绕过预设的访问限制。或空文件名。其影响是修改客户端目标目录的权限。

解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://github.com/openssh/openssh-portable/commit/6010c0303a422a9c5fa8860c061bf7105eb7f8b2
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp cloud_backup - -
运行在以下环境
应用 netapp element_software - -
运行在以下环境
应用 netapp ontap_select_deploy - -
运行在以下环境
应用 netapp steelstore_cloud_integrated_storage - -
运行在以下环境
应用 netapp storage_automation_store - -
运行在以下环境
应用 openbsd openssh * Up to
(including)
7.9
运行在以下环境
应用 winscp winscp * Up to
(including)
5.13
运行在以下环境
系统 alpine_3.10 openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 alpine_3.11 openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 alpine_3.12 openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 alpine_3.13 openssh * Up to
(excluding)
2020.79-r0
运行在以下环境
系统 alpine_3.14 openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 alpine_3.15 openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 alpine_3.6 openssh * Up to
(excluding)
7.5_p1-r4
运行在以下环境
系统 alpine_3.7 openssh * Up to
(excluding)
7.5_p1-r10
运行在以下环境
系统 alpine_3.8 openssh * Up to
(excluding)
7.7_p1-r4
运行在以下环境
系统 alpine_3.9 openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 alpine_edge openssh * Up to
(excluding)
7.9_p1-r3
运行在以下环境
系统 amazon_2 openssh * Up to
(excluding)
7.4p1-16.amzn2.0.6
运行在以下环境
系统 amazon_AMI openssh * Up to
(excluding)
7.4p1-21.73.amzn1
运行在以下环境
系统 centos_8 openssh * Up to
(excluding)
8.0p1-3.el8
运行在以下环境
系统 debian_8 openssh * Up to
(excluding)
1:6.7p1-5+deb8u6
运行在以下环境
系统 debian_9 openssh * Up to
(excluding)
1:7.4p1-10+deb9u5
运行在以下环境
系统 fedora_28 openssh * Up to
(excluding)
7.8p1-4.fc28
运行在以下环境
系统 fedora_29 openssh * Up to
(excluding)
7.9p1-3.fc29
运行在以下环境
系统 opensuse_Leap_15.0 openssh * Up to
(excluding)
7.6p1-lp150.8.9.1
运行在以下环境
系统 opensuse_Leap_42.3 openssh * Up to
(excluding)
7.2p2-29.1
运行在以下环境
系统 oracle_8 openssh * Up to
(excluding)
8.0p1-3.el8
运行在以下环境
系统 redhat_8 openssh * Up to
(excluding)
8.0p1-3.el8
运行在以下环境
系统 suse_11_SP4 openssh * Up to
(excluding)
36.12.1
运行在以下环境
系统 suse_12_SP3 openssh * Up to
(excluding)
74.35.1
运行在以下环境
系统 suse_12_SP4 openssh * Up to
(excluding)
74.35.1
运行在以下环境
系统 ubuntu_14.04 openssh * Up to
(excluding)
1:6.6p1-2ubuntu2.12
运行在以下环境
系统 ubuntu_16.04 openssh * Up to
(excluding)
1:7.2p2-4ubuntu2.7
运行在以下环境
系统 ubuntu_18.04 openssh * Up to
(excluding)
1:7.6p1-4ubuntu0.2
运行在以下环境
系统 ubuntu_20.04 openssh * Up to
(excluding)
1:7.9p1-5
运行在以下环境
系统 ubuntu_21.04 openssh * Up to
(excluding)
1:7.9p1-5
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-863 授权机制不正确
阿里云安全产品覆盖情况