低危 GNU C Library 资源管理错误漏洞

CVE编号

CVE-2018-20796

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-02-26
漏洞描述
GNU C Library(glibc,libc6)是一种按照LGPL许可协议发布的开源免费的C语言编译程序。
GNU C Library 2.29及之前版本中的posix/regexec.c文件的check_dst_limits_calc_pos_1存在资源管理错误漏洞。

解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
https://www.gnu.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu glibc * Up to
(including)
2.29
运行在以下环境
应用 netapp cloud_backup * -
运行在以下环境
应用 netapp ontap_select_deploy_administration_utility - -
运行在以下环境
应用 netapp steelstore_cloud_integrated_storage - -
运行在以下环境
系统 debian_10 glibc * Up to
(including)
2.28-10+deb10u1
运行在以下环境
系统 debian_11 glibc * Up to
(including)
2.31-13+deb11u3
运行在以下环境
系统 debian_12 glibc * Up to
(including)
2.33-7
运行在以下环境
系统 debian_9 glibc * Up to
(including)
2.24-11+deb9u4
运行在以下环境
系统 debian_sid glibc * Up to
(including)
2.33-7
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-674 未经控制的递归
阿里云安全产品覆盖情况