低危 Oracle Outside In Technology 12.2.1.3.0/12.2.1.4.0 Installation 拒绝服务漏洞

CVE编号

CVE-2018-20843

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-06-25
漏洞描述
在2.2.7之前的Expat中的libexpat中,包含包含大量冒号的XML名称的XML输入可能使XML解析器在处理时消耗大量RAM和CPU资源(足以用于拒绝服务攻击) 。<br>
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libexpat expat * Up to
(excluding)
2.2.7
运行在以下环境
系统 alibaba_cloud_linux_2.1903 expat * Up to
(excluding)
2.1.0-12.1.al7
运行在以下环境
系统 alpine_3.10 expat * Up to
(excluding)
2.2.7-r0
运行在以下环境
系统 alpine_3.11 expat * Up to
(excluding)
2.2.7-r0
运行在以下环境
系统 alpine_3.12 expat * Up to
(excluding)
2.2.7-r0
运行在以下环境
系统 alpine_3.13 expat * Up to
(excluding)
2.2.7-r0
运行在以下环境
系统 alpine_3.14 expat * Up to
(excluding)
2.2.7-r0
运行在以下环境
系统 alpine_3.15 expat * Up to
(excluding)
2.2.7-r0
运行在以下环境
系统 alpine_3.16 expat * Up to
(excluding)
2.2.7-r0
运行在以下环境
系统 alpine_3.7 expat * Up to
(excluding)
2.2.7-r0
运行在以下环境
系统 alpine_3.8 expat * Up to
(excluding)
2.2.7-r0
运行在以下环境
系统 alpine_3.9 expat * Up to
(excluding)
2.2.7-r0
运行在以下环境
系统 alpine_edge expat * Up to
(excluding)
2.2.7-r0
运行在以下环境
系统 amazon_2 expat * Up to
(excluding)
2.1.0-12.amzn2
运行在以下环境
系统 amazon_AMI expat * Up to
(excluding)
2.1.0-12.24.amzn1
运行在以下环境
系统 centos_8 expat * Up to
(excluding)
2.2.5-4.el8
运行在以下环境
系统 debian_8 expat * Up to
(excluding)
2.1.0-6+deb8u6
运行在以下环境
系统 debian_9 expat * Up to
(excluding)
2.2.0-2+deb9u2
运行在以下环境
系统 fedora_29 expat * Up to
(excluding)
2.2.7-1.fc29
运行在以下环境
系统 fedora_30 expat * Up to
(excluding)
2.2.7-1.fc30
运行在以下环境
系统 opensuse_Leap_15.0 expat * Up to
(excluding)
2.2.5-lp151.3.3.1
运行在以下环境
系统 opensuse_Leap_15.1 expat * Up to
(excluding)
2.2.5-lp151.3.3.1
运行在以下环境
系统 oracle_7 expat * Up to
(excluding)
2.1.0-12.el7
运行在以下环境
系统 oracle_8 expat * Up to
(excluding)
2.2.5-4.el8
运行在以下环境
系统 redhat_7 expat * Up to
(excluding)
0:2.1.0-12.el7
运行在以下环境
系统 redhat_8 expat * Up to
(excluding)
2.2.5-4.el8
运行在以下环境
系统 suse_12 expat * Up to
(excluding)
2.1.0-21.6
运行在以下环境
系统 suse_12_SP4 expat * Up to
(excluding)
2.1.0-21.6.1
运行在以下环境
系统 ubuntu_14.04 expat * Up to
(excluding)
2.1.0-4ubuntu1.4+esm1
运行在以下环境
系统 ubuntu_16.04 expat * Up to
(excluding)
2.1.0-7ubuntu0.16.04.4
运行在以下环境
系统 ubuntu_16.04.7_lts expat * Up to
(excluding)
2.1.0-7ubuntu0.16.04.4
运行在以下环境
系统 ubuntu_18.04 expat * Up to
(excluding)
2.2.5-3ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts expat * Up to
(excluding)
2.2.5-3ubuntu0.1
运行在以下环境
系统 ubuntu_18.10 expat * Up to
(excluding)
2.2.6-1ubuntu0.18.10
运行在以下环境
系统 ubuntu_20.04 expat * Up to
(excluding)
2.2.6-2
运行在以下环境
系统 ubuntu_21.04 expat * Up to
(excluding)
2.2.6-2
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-611 XML外部实体引用的不恰当限制(XXE)
阿里云安全产品覆盖情况