低危 对invokeinterface instruction的验证不充分

CVE编号

CVE-2018-2582

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-01-18
漏洞描述
Java SE中的漏洞,Oracle Java SE的Java SE嵌入式组件(子组件:Hotspot)。受影响的支持版本是Java SE:8u152和9.0.1; Java SE Embedded:8u151。易于利用的漏洞允许未经身份验证的攻击者通过多种协议进行网络访问,从而危及Java SE,Java SE Embedded。成功的攻击需要攻击者以外的人进行人工交互。成功攻击此漏洞可能导致对关键数据或所有Java SE,Java SE Embedded可访问数据的未授权创建,删除或修改访问。注意:此漏洞适用于Java的客户端和服务器部署。可以通过 sandboxed Java Web Start applications 和 sandboxed Java applets利用此漏洞。它还可以通过向指定组件中的API提供数据来利用,而无需 sandboxed Java Web Start applications 和sandboxed Java applets,例如通过Web服务。 CVSS 3.0基本分数6.5(完整性影响)。 CVSS矢量:(CVSS:3.0 / AV:N / AC:L / PR:N / UI:R / S:U / C:N / I:H / A:N)。

解决建议
目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
http://www.oracle.com/technetwork/security-advisory/cpujan2018-3236628.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 hp xp7_command_view * From
(including)
8.6.2-01
运行在以下环境
应用 hp xp_command_view * From
(including)
8.6.2-01
运行在以下环境
应用 hp xp_p9000_command_view * From
(including)
8.6.2-01
运行在以下环境
应用 oracle jdk 1.8.0 -
运行在以下环境
应用 oracle jdk 1.9.0.1 -
运行在以下环境
应用 oracle jre 1.8.0 -
运行在以下环境
应用 oracle jre 1.9.0.1 -
运行在以下环境
应用 redhat satellite 5.8 -
运行在以下环境
应用 schneider-electric struxureware_data_center_expert * Up to
(excluding)
7.6.0
运行在以下环境
系统 amazon_2 openjdk-8 * Up to
(excluding)
1.8.0-openjdk-debug-1.8.0.161-0.b14.amzn2
运行在以下环境
系统 amazon_AMI openjdk-8 * Up to
(excluding)
1.8.0-openjdk-javadoc-zip-1.8.0.161-0.b14.36.amzn1
运行在以下环境
系统 centos_6 openjdk-8 * Up to
(excluding)
1.8.0.161-3.b14.el6_9
运行在以下环境
系统 debian_9 openjdk-8 * Up to
(excluding)
8u162-b12-1~deb9u1
运行在以下环境
系统 opensuse_Leap_42.3 openjdk-8 * Up to
(excluding)
1.8.0.161-21.1
运行在以下环境
系统 oracle_6 openjdk-8 * Up to
(excluding)
1.8.0.161-3.b14.el6_9
运行在以下环境
系统 oracle_7 openjdk-8 * Up to
(excluding)
1.8.0.161-0.b14.el7_4
运行在以下环境
系统 redhat_7 java-1.8.0-openjdk * Up to
(excluding)
1:1.8.0.161-3.b14.el6_9
运行在以下环境
系统 redhat_7 java-1.8.0-oracle * Up to
(excluding)
1:1.8.0.161-1jpp.2.el7
运行在以下环境
系统 suse_11_SP4 openjdk-8 * Up to
(excluding)
1.7.1_sr4.20-26.13.1
运行在以下环境
系统 suse_12 java-1_8_0-openjdk * Up to
(excluding)
1.8.0.161-27.13
运行在以下环境
系统 suse_12_SP2 openjdk-8 * Up to
(excluding)
1.8.0.161-27.13.1
运行在以下环境
系统 suse_12_SP3 openjdk-8 * Up to
(excluding)
1.8.0.161-27.13.1
运行在以下环境
系统 ubuntu_16.04 openjdk-8 * Up to
(excluding)
8u162-b12-0ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_16.04.7_lts openjdk-8 * Up to
(excluding)
8u162-b12-0ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_16.04_lts openjdk-8 * Up to
(excluding)
8u162-b12-0ubuntu0.16.04.2
运行在以下环境
系统 ubuntu_18.04.5_lts openjdk-8 * Up to
(excluding)
8u162-b12-1
运行在以下环境
系统 ubuntu_18.04_lts openjdk-8 * Up to
(excluding)
8u162-b12-1
运行在以下环境
系统 ubuntu_18.10 openjdk-8 * Up to
(excluding)
8u162-b12-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况