低危 Oracle Java SE 7u171/8u162/10 JAXP 拒绝服务漏洞

CVE编号

CVE-2018-2799

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-04-19
漏洞描述
java se、java se Embedded、oracle java se的jrockit组件中的漏洞(子组件:jaxp)。受影响的版本包括java se:7u 171、8u162和10;javase Embedded:8u161;jrockit:r28.3.17。易被攻击的漏洞允许未经身份验证的攻击者通过多个协议进行网络访问,从而危及java se、java se Embedded和jrockit。对此漏洞的成功攻击可能导致未经授权的能力,导致java se、java se Embedded、jrockit的部分拒绝服务(部分DoS)。注意:适用于Java的客户端和服务器部署。此漏洞可通过sandboxed Java Web Start applications 或者 sandboxed Java applets利用。它还可以通过向指定组件中的API提供数据来利用,而无需使用sandboxed Java Web Start applications 或者 sandboxed Java applets,例如通过Web服务。CVSS3.0基础得分5.3(可用性影响)。CVSS矢量:(cvss:3.0/av:n/ac:l/pr:n/ui:n/s:u/c:n/i:n/a:l). 

解决建议
厂商已发布漏洞修复程序,请及时关注更新:
http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html
参考链接
http://www.oracle.com/technetwork/security-advisory/cpuapr2018-3678067.html
http://www.securityfocus.com/bid/103872
http://www.securitytracker.com/id/1040697
https://access.redhat.com/errata/RHSA-2018:1188
https://access.redhat.com/errata/RHSA-2018:1191
https://access.redhat.com/errata/RHSA-2018:1201
https://access.redhat.com/errata/RHSA-2018:1202
https://access.redhat.com/errata/RHSA-2018:1204
https://access.redhat.com/errata/RHSA-2018:1206
https://access.redhat.com/errata/RHSA-2018:1270
https://access.redhat.com/errata/RHSA-2018:1278
https://access.redhat.com/errata/RHSA-2018:1721
https://access.redhat.com/errata/RHSA-2018:1722
https://access.redhat.com/errata/RHSA-2018:1723
https://access.redhat.com/errata/RHSA-2018:1724
https://access.redhat.com/errata/RHSA-2018:1974
https://access.redhat.com/errata/RHSA-2018:1975
https://help.ecostruxureit.com/display/public/UADCE725/Security+fixes+in+Stru...
https://lists.apache.org/thread.html/49dc6702104a86ecbb40292dcd329ce9ae4c32b7...
https://lists.apache.org/thread.html/b53d4601ecd9ec63c799dbe1bc5b78e0d52f4cef...
https://lists.apache.org/thread.html/r449b5d89c7b2ba3762584cf6c38e01867d4b247...
https://security.gentoo.org/glsa/201903-14
https://security.netapp.com/advisory/ntap-20180419-0001/
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-...
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-...
https://usn.ubuntu.com/3644-1/
https://usn.ubuntu.com/3691-1/
https://www.debian.org/security/2018/dsa-4185
https://www.debian.org/security/2018/dsa-4225
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache xerces-j * Up to
(excluding)
2.12.0
运行在以下环境
应用 hp xp7_command_view * -
运行在以下环境
应用 oracle jdk 1.10.0 -
运行在以下环境
应用 oracle jdk 1.7.0 -
运行在以下环境
应用 oracle jdk 1.8.0 -
运行在以下环境
应用 oracle jre 1.10.0 -
运行在以下环境
应用 oracle jre 1.7.0 -
运行在以下环境
应用 oracle jre 1.8.0 -
运行在以下环境
应用 oracle jrockit r28.3.17 -
运行在以下环境
应用 redhat satellite 5.6 -
运行在以下环境
应用 redhat satellite 5.7 -
运行在以下环境
应用 redhat satellite 5.8 -
运行在以下环境
应用 schneider-electric struxureware_data_center_expert * Up to
(excluding)
7.6.0
运行在以下环境
系统 amazon_2 openjdk-7 * Up to
(excluding)
1.8.0-openjdk-javadoc-1.8.0.171-7.b10.amzn2
运行在以下环境
系统 amazon_AMI openjdk-7 * Up to
(excluding)
1.8.0-openjdk-src-1.8.0.171-7.b10.37.amzn1
运行在以下环境
系统 centos_6 openjdk-7 * Up to
(excluding)
devel-1.8.0.171-3.b10.el6_9
运行在以下环境
系统 centos_7 openjdk-7 * Up to
(excluding)
1.7.0.181-2.6.14.5.el7
运行在以下环境
系统 debian_8 openjdk-7 * Up to
(excluding)
7u95-2.6.4-1~deb8u1
运行在以下环境
系统 debian_9 openjdk-7 * Up to
(excluding)
8u171-b11-1~deb9u1
运行在以下环境
系统 opensuse_Leap_15.0 openjdk-7 * Up to
(excluding)
1.8.0.171-lp150.2.3.1
运行在以下环境
系统 opensuse_Leap_42.3 openjdk-7 * Up to
(excluding)
1.8.0.171-24.1
运行在以下环境
系统 oracle_6 openjdk-7 * Up to
(excluding)
1.7.0.181-2.6.14.1.0.1.el6_9
运行在以下环境
系统 oracle_7 openjdk-7 * Up to
(excluding)
1.7.0.181-2.6.14.5.0.1.el7
运行在以下环境
系统 redhat_6 java-1.8.0-openjdk * Up to
(excluding)
1:1.8.0.171-3.b10.el6_9
运行在以下环境
系统 redhat_7 java-1.8.0-openjdk * Up to
(excluding)
1:1.8.0.171-7.b10.el7
运行在以下环境
系统 suse_11_SP4 openjdk-7 * Up to
(excluding)
1.7.1_sr4.25-26.26.1
运行在以下环境
系统 suse_12 java-1_7_0-openjdk * Up to
(excluding)
1.7.0.181-43.15
运行在以下环境
系统 suse_12_SP3 openjdk-7 * Up to
(excluding)
1.7.0.181-43.15.2
运行在以下环境
系统 ubuntu_14.04.6_lts openjdk-7 * Up to
(excluding)
7u181-2.6.14-0ubuntu0.1
运行在以下环境
系统 ubuntu_16.04 openjdk-8 * Up to
(excluding)
8u171-b11-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_16.04.7_lts openjdk-8 * Up to
(excluding)
8u171-b11-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04 openjdk-8 * Up to
(excluding)
8u171-b11-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts openjdk-8 * Up to
(excluding)
8u171-b11-0ubuntu0.18.04.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况