中危 Rails Sprockets <= 3.7.1 任意文件读取漏洞(CVE-2018-3760)

CVE编号

CVE-2018-3760

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2018-06-27
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
Sprockets中存在信息泄露漏洞。在生产中使用Sprockets服务器时,可以使用特制的请求来访问存在于应用程序根目录之外的文件系统上的文件。受影响的版本:4.0.0.beta7及更低版本,3.7.1及更低版本,2.12.4及更低版本。<br>
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat cloudforms 4.5 -
运行在以下环境
应用 redhat cloudforms 4.6 -
运行在以下环境
应用 sprockets_project sprockets * From
(including)
2.0.0
Up to
(including)
2.12.4
运行在以下环境
应用 sprockets_project sprockets * From
(including)
3.0.0
Up to
(including)
3.7.1
运行在以下环境
应用 sprockets_project sprockets 4.0.0 -
运行在以下环境
系统 debian_8 ruby-sprockets * Up to
(excluding)
2.12.3-1+deb8u1
运行在以下环境
系统 debian_9 ruby-sprockets * Up to
(excluding)
3.7.0-1+deb9u1
运行在以下环境
系统 fedora_27 ruby-sprockets * Up to
(excluding)
3.7.2-1.fc27
运行在以下环境
系统 fedora_28 ruby-sprockets * Up to
(excluding)
3.7.2-1.fc28
运行在以下环境
系统 opensuse_Leap_15.0 ruby-sprockets * Up to
(excluding)
3.7.2-lp150.2.3.1
运行在以下环境
系统 opensuse_Leap_42.3 ruby-sprockets * Up to
(excluding)
3.3.5-5.3.1
运行在以下环境
系统 ubuntu_18.04 ruby-sprockets * Up to
(excluding)
3.7.0-1+deb9u1build0.18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts ruby-sprockets * Up to
(excluding)
3.7.0-1+deb9u1build0.18.04.1
阿里云评分
6.6
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况