低危 Wmi _ set _ ie ()可能会导致内存损坏

CVE编号

CVE-2018-5848

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-06-13
漏洞描述
在函数wmi_set_ie()中,length validation code不能正确处理无符号整数溢出。因此,'ie_len'参数的大值可能导致使用Linux内核从CAF(Android for MSM,Firefox OS for MSM,QRD Android)的所有Android版本中缓冲区溢出。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://source.android.com/security/bulletin/pixel/2018-05-01
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat virtualization_host 4.0 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 google android - -
运行在以下环境
系统 redhat enterprise_linux_desktop 7.0 -
运行在以下环境
系统 redhat enterprise_linux_server 7.0 -
运行在以下环境
系统 redhat enterprise_linux_workstation 7.0 -
运行在以下环境
系统 redhat_7 bpftool * Up to
(excluding)
0:3.10.0-957.el7
运行在以下环境
系统 redhat_7 kernel-rt * Up to
(excluding)
0:3.10.0-957.rt56.910.el7
运行在以下环境
系统 sles_12 kernel-default-extra * Up to
(excluding)
4.12.14-94.41
运行在以下环境
系统 ubuntu_14.04_lts linux-aws * Up to
(excluding)
4.4.0-1039.42
运行在以下环境
系统 ubuntu_16.04_lts linux * Up to
(excluding)
4.4.0-143.169
运行在以下环境
系统 ubuntu_18.04_lts linux * Up to
(excluding)
4.15.0-58.64
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况