低危 Puppet Enterprise远程代码执行漏洞

CVE编号

CVE-2018-6508

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-02-10
漏洞描述
Puppet是美国Puppet实验室的一套基于客户端/服务器(C/S)架构的配置管理工具,它可用于管理配置文件、用户、cron任务、软件包、系统服务等。Puppet Enterprise是一个企业版。

Puppet Enterprise 2017.3.3之前的2017.3.x版本中存在远程代码执行漏洞。远程攻击者可借助特制的字符串利用该漏洞执行代码。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://puppet.com/security/cve/CVE-2018-6508
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet * From
(including)
2017.3.0
Up to
(including)
2017.3.2
运行在以下环境
系统 debian_10 puppet-module-puppetlabs-apache * Up to
(including)
3.4.0-1
运行在以下环境
系统 debian_10 puppet-module-puppetlabs-apt * Up to
(including)
3.4.0-1
运行在以下环境
系统 debian_10 puppet-module-puppetlabs-mysql * Up to
(including)
3.4.0-1
运行在以下环境
系统 debian_11 puppet-module-puppetlabs-apache * Up to
(including)
5.5.0-2
运行在以下环境
系统 debian_11 puppet-module-puppetlabs-apt * Up to
(including)
5.5.0-2
运行在以下环境
系统 debian_11 puppet-module-puppetlabs-mysql * Up to
(including)
5.5.0-2
运行在以下环境
系统 debian_12 puppet-module-puppetlabs-apache * Up to
(including)
5.5.0-2
运行在以下环境
系统 debian_9 puppet-module-puppetlabs-apache * Up to
(including)
1.10.0-1
运行在以下环境
系统 debian_9 puppet-module-puppetlabs-apt * Up to
(including)
1.10.0-1
运行在以下环境
系统 debian_9 puppet-module-puppetlabs-mysql * Up to
(including)
1.10.0-1
运行在以下环境
系统 debian_sid puppet-module-puppetlabs-apache * Up to
(including)
5.5.0-2
运行在以下环境
系统 debian_sid puppet-module-puppetlabs-apt * Up to
(including)
5.5.0-2
运行在以下环境
系统 debian_sid puppet-module-puppetlabs-mysql * Up to
(including)
5.5.0-2
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-134 使用外部控制的格式字符串
阿里云安全产品覆盖情况