Puppet Enterprise Console 跨站脚本漏洞

CVE编号

CVE-2018-6510

利用情况

暂无

补丁情况

N/A

披露时间

2018-05-09
漏洞描述
Puppet是美国Puppet实验室的一套基于客户端/服务器(C/S)架构的配置管理工具,它可用于管理配置文件、用户、cron任务、软件包、系统服务等。Puppet Enterprise是它的企业版。Puppet Enterprise Console是其中的一个控制台程序。
Puppet Enterprise 2017.3.6之前的2017.3.x版本中的Puppet Enterprise Console存在跨站脚本洞。远程攻击者可利用该漏洞向Puppet Enterprise Console中注入脚本。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://puppet.com/security/cve/CVE-2018-6510
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppetlabs puppet * From
(including)
2017.3
Up to
(excluding)
2017.3.6
CVSS3评分
5.4
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    已更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况