Puppet Agent任意代码执行漏洞

CVE编号

CVE-2018-6515

利用情况

暂无

补丁情况

N/A

披露时间

2018-06-12
漏洞描述
Puppet是美国Puppet实验室的一套基于客户端/服务器(C/S)架构的配置管理工具。Puppet Agent for Windows是其中的一个基于Windows平台的代理程序。

基于Windows平台的Puppet Agent 1.10.13之前的1.10.x版本、5.3.7之前的5.3.x版本和5.5.2之前5.5.x版本中存在安全漏洞。攻击者可借助特制的配置文件利用该漏洞使pxp-agent加载任意代码。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://puppet.com/security/cve/CVE-2018-6515
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 puppet puppet * From
(including)
1.10.0
Up to
(excluding)
1.10.13
运行在以下环境
应用 puppet puppet * From
(including)
5.3.0
Up to
(excluding)
5.3.7
运行在以下环境
应用 puppet puppet * From
(including)
5.5.0
Up to
(excluding)
5.5.2
CVSS3评分
7.8
  • 攻击路径
    本地
  • 攻击复杂度
  • 权限要求
  • 影响范围
    未更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况