低危 Google Go命令执行漏洞

CVE编号

CVE-2018-6574

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-02-08
漏洞描述
Google Go是美国谷歌(Google)公司的一种针对多处理器系统应用程序的编程进行了优化的编程语言。

Google Go 1.8.7之前版本、1.9.4之前的1.9.x版本和1.10rc2之前的1.10 pre-releases版本中存在安全漏洞。远程攻击者可利用该漏洞执行命令。
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/golang/go/issues/23672
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 golang go * Up to
(including)
1.8.6
运行在以下环境
应用 golang go 1.10 -
运行在以下环境
应用 golang go 1.9 -
运行在以下环境
应用 golang go 1.9.1 -
运行在以下环境
应用 golang go 1.9.2 -
运行在以下环境
应用 golang go 1.9.3 -
运行在以下环境
系统 alpine_3.10 go * Up to
(excluding)
1.9.4-r0
运行在以下环境
系统 alpine_3.11 go * Up to
(excluding)
1.9.4-r0
运行在以下环境
系统 alpine_3.12 go * Up to
(excluding)
1.9.4-r0
运行在以下环境
系统 alpine_3.13 go * Up to
(excluding)
1.9.4-r0
运行在以下环境
系统 alpine_3.14 go * Up to
(excluding)
1.9.4-r0
运行在以下环境
系统 alpine_3.15 go * Up to
(excluding)
1.9.4-r0
运行在以下环境
系统 alpine_3.16 go * Up to
(excluding)
1.9.4-r0
运行在以下环境
系统 alpine_3.7 go * Up to
(excluding)
1.9.4-r0
运行在以下环境
系统 alpine_3.8 go * Up to
(excluding)
1.9.4-r0
运行在以下环境
系统 alpine_3.9 go * Up to
(excluding)
1.9.4-r0
运行在以下环境
系统 alpine_edge go * Up to
(excluding)
1.9.4-r0
运行在以下环境
系统 amazon_2 go * Up to
(excluding)
1.9.4-1.amzn2
运行在以下环境
系统 amazon_AMI go * Up to
(excluding)
1.9.4-2.44.amzn1
运行在以下环境
系统 debian_9 go * Up to
(including)
1.7.4-2+deb9u1
运行在以下环境
系统 fedora_26 go * Up to
(excluding)
1.8.7-1.fc26
运行在以下环境
系统 fedora_27 go * Up to
(excluding)
1.9.4-1.fc27
运行在以下环境
系统 fedora_EPEL_6 go * Up to
(excluding)
1.9.4-1.el6
运行在以下环境
系统 opensuse_Leap_42.3 go * Up to
(excluding)
1.8.7-5.1
运行在以下环境
系统 redhat_7 golang * Up to
(excluding)
0:1.9.4-1.el7
运行在以下环境
系统 ubuntu_18.04.5_lts golang-1.9 * Up to
(excluding)
1.9.4-1ubuntu1
运行在以下环境
系统 ubuntu_18.10 golang-1.9 * Up to
(excluding)
1.9.4-1ubuntu1
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-94 对生成代码的控制不恰当(代码注入)
阿里云安全产品覆盖情况