低危 ntp 至 4.2.8p6/4.3.91 ntpd Sybil 数据处理漏洞

CVE编号

CVE-2018-7170

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-07
漏洞描述
4.2.8p7之前的ntp 4.2.x中的nptd和4.3.92之前的4.3.x中的nptd允许知道私有对称密钥的经过身份验证的用户创建任意多个临时关联,以赢得ntpd的时钟选择,并通过Sybil攻击修改受害者的时钟。这个问题的存在是因为CVE-2016-1549的修复不完整。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
http://support.ntp.org/bin/view/Main/NtpBug3415
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 hpe hpux-ntp * Up to
(excluding)
c.4.2.8.4.0
运行在以下环境
应用 netapp hci - -
运行在以下环境
应用 netapp solidfire - -
运行在以下环境
应用 ntp ntp * From
(including)
4.2.0
Up to
(excluding)
4.2.8
运行在以下环境
应用 ntp ntp * From
(including)
4.3.0
Up to
(excluding)
4.3.92
运行在以下环境
应用 ntp ntp 4.2.8 -
运行在以下环境
应用 synology diskstation_manager * From
(including)
5.2
Up to
(excluding)
6.1.6-15266
运行在以下环境
应用 synology router_manager * From
(including)
1.1
Up to
(excluding)
1.1.6-6931-3
运行在以下环境
应用 synology skynas * Up to
(excluding)
6.1.5-15254
运行在以下环境
应用 synology virtual_diskstation_manager * Up to
(excluding)
6.1.6-15266
运行在以下环境
系统 amazon_AMI ntp * Up to
(excluding)
4.2.8p11-1.37.amzn1
运行在以下环境
系统 debian_9 ntp * Up to
(excluding)
4.2.8p10+dfsg-3+deb9u2
运行在以下环境
系统 fedora_26 ntp * Up to
(excluding)
4.2.8p11-1.fc26
运行在以下环境
系统 fedora_27 ntp * Up to
(excluding)
4.2.8p11-1.fc27
运行在以下环境
系统 fedora_28 ntp * Up to
(excluding)
4.2.8p12-1.fc28
运行在以下环境
系统 opensuse_Leap_15.0 ntp * Up to
(excluding)
4.2.8p12-lp150.3.3.1
运行在以下环境
系统 opensuse_Leap_42.3 ntp * Up to
(excluding)
4.2.8p12-31.6.1
运行在以下环境
系统 suse_11_SP4 ntp * Up to
(excluding)
4.2.8p11-64.4.1
运行在以下环境
系统 suse_12_SP3 ntp * Up to
(excluding)
4.2.8p11-64.5.1
运行在以下环境
系统 ubuntu_20.04 ntp * Up to
(excluding)
1:4.2.8p11+dfsg-1ubuntu1
运行在以下环境
系统 ubuntu_21.04 ntp * Up to
(excluding)
1:4.2.8p11+dfsg-1ubuntu1
阿里云评分
2.4
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况