低危 代码执行漏洞

CVE编号

CVE-2018-7187

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-02-17
漏洞描述
当使用-insecure命令行选项时,Go 1.9.4中的“ go get”实现不验证导入路径(get/vcs.go仅在字符串中的任何位置检查'://'),允许远程攻击者通过精心制作的网站执行任意OS命令。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 golang go * Up to
(excluding)
1.10.1
运行在以下环境
系统 amazon_AMI golang * Up to
(excluding)
1.9.4-2.44.amzn1
运行在以下环境
系统 debian_7 golang * Up to
(excluding)
2:1.0.2-1.1+deb7u3
运行在以下环境
系统 debian_9 golang * Up to
(excluding)
1.7.4-2+deb9u1
运行在以下环境
系统 fedora_27 golang * Up to
(excluding)
1.9.4-2.fc27
运行在以下环境
系统 fedora_28 golang * Up to
(excluding)
1.10-2.fc28
运行在以下环境
系统 fedora_EPEL_6 golang * Up to
(excluding)
1.9.4-1.el6
运行在以下环境
系统 opensuse_Leap_15.0 golang * Up to
(excluding)
1.9.7-lp150.2.4.1
运行在以下环境
系统 opensuse_Leap_42.3 golang * Up to
(excluding)
1.9.7-37.2
运行在以下环境
系统 ubuntu_18.04.5_lts golang-1.8 * Up to
(excluding)
1.8.1-1+deb9u1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-78 OS命令中使用的特殊元素转义处理不恰当(OS命令注入)
阿里云安全产品覆盖情况