低危 Ceph up to 12.2.3/13.0.1 rgw_civetweb.cc RGWCivetWeb::init_env HTTP Header 拒绝服务漏洞

CVE编号

CVE-2018-7262

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-20
漏洞描述
Red Hat Ceph是美国红帽(Red Hat)公司的一套Linux PB级分布式文件系统。该系统的主要目标是设计成基于POSIX(可移植操作系统接口)的没有单点故障的分布式文件系统,使数据能容错和无缝的复制。radosgw是其中的一个对象存储组件。

Red Hat Ceph 12.2.3之前版本和13.0.1之前的13.x版本中的radosgw的rgw_civetweb.cc文件的‘RGWCivetWeb::init_env’函数存在安全漏洞,该漏洞源于程序未能正确的处理畸形的HTTP包头。攻击者可利用该漏洞造成拒绝服务。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
http://tracker.ceph.com/issues/23039
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ceph * Up to
(excluding)
12.2.3
运行在以下环境
应用 redhat ceph 13.0.0 -
运行在以下环境
应用 redhat ceph 13.0.1 -
运行在以下环境
系统 fedora_27 +git.1524775272.5e7ea8cf03 * Up to
(excluding)
12.2.4-1.fc27
运行在以下环境
系统 fedora_27 ceph * Up to
(excluding)
12.2.4-1.fc27
运行在以下环境
系统 fedora_27 ceph-common * Up to
(excluding)
12.2.4-1.fc27
运行在以下环境
系统 fedora_27 libcephfs2 * Up to
(excluding)
12.2.4-1.fc27
运行在以下环境
系统 fedora_27 librados2 * Up to
(excluding)
12.2.4-1.fc27
运行在以下环境
系统 fedora_27 libradosstriper1 * Up to
(excluding)
12.2.4-1.fc27
运行在以下环境
系统 fedora_27 librbd1 * Up to
(excluding)
12.2.4-1.fc27
运行在以下环境
系统 fedora_27 librgw2 * Up to
(excluding)
12.2.4-1.fc27
运行在以下环境
系统 fedora_27 python-cephfs * Up to
(excluding)
12.2.4-1.fc27
运行在以下环境
系统 fedora_27 python-rados * Up to
(excluding)
12.2.4-1.fc27
运行在以下环境
系统 fedora_27 python-rbd * Up to
(excluding)
12.2.4-1.fc27
运行在以下环境
系统 fedora_27 python-rgw * Up to
(excluding)
12.2.4-1.fc27
运行在以下环境
系统 opensuse_Leap_42.3 +git.1524775272.5e7ea8cf03 * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 ceph * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 ceph-common * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 libcephfs2 * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 librados2 * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 libradosstriper1 * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 librbd1 * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 librgw2 * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 python-cephfs * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 python-rados * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 python-rbd * Up to
(excluding)
12.2.5
运行在以下环境
系统 opensuse_Leap_42.3 python-rgw * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 +git.1524775272.5e7ea8cf03 * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 ceph * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 ceph-common * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 libcephfs2 * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 librados2 * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 libradosstriper1 * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 librbd1 * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 librgw2 * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 python-cephfs * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 python-rados * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 python-rbd * Up to
(excluding)
12.2.5
运行在以下环境
系统 suse_12_SP3 python-rgw * Up to
(excluding)
12.2.5
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-476 空指针解引用
阿里云安全产品覆盖情况