低危 transport.py中的身份验证绕过

CVE编号

CVE-2018-7750

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-14
漏洞描述
在1.17.6之前,1.18.5之前的1.18.x,2.0.8之前的2.0.x,2.1.5之前的2.1.x,2.2.3之前的2.2.x,2.3.x在2.3.2之前,2.4.1之前的Paramiko中的SSH server implementation中的transport.py,没有正确检查在处理其他请求之前是否完成了身份验证,如channel-open所示。自定义SSH客户端可以简单地跳过身份验证步骤。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/paramiko/paramiko/blob/master/sites/www/changelog.rst
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 paramiko paramiko * Up to
(excluding)
1.17.6
运行在以下环境
应用 paramiko paramiko * From
(including)
1.18.0
Up to
(excluding)
1.18.5
运行在以下环境
应用 paramiko paramiko * From
(including)
2.0.0
Up to
(excluding)
2.0.8
运行在以下环境
应用 paramiko paramiko * From
(including)
2.1.0
Up to
(excluding)
2.1.5
运行在以下环境
应用 paramiko paramiko * From
(including)
2.2.0
Up to
(excluding)
2.2.3
运行在以下环境
应用 paramiko paramiko * From
(including)
2.3.0
Up to
(excluding)
2.3.2
运行在以下环境
应用 paramiko paramiko 2.4.0 -
运行在以下环境
应用 redhat ansible_engine 2.0 -
运行在以下环境
应用 redhat ansible_engine 2.4 -
运行在以下环境
应用 redhat cloudforms 4.5 -
运行在以下环境
应用 redhat cloudforms 4.6 -
运行在以下环境
应用 redhat virtualization 4.1 -
运行在以下环境
系统 alpine_3.11 paramiko * Up to
(excluding)
2.4.1-r0
运行在以下环境
系统 alpine_3.12 paramiko * Up to
(excluding)
2.4.1-r0
运行在以下环境
系统 alpine_3.13 paramiko * Up to
(excluding)
2.4.1-r0
运行在以下环境
系统 alpine_3.14 paramiko * Up to
(excluding)
2.4.1-r0
运行在以下环境
系统 alpine_3.15 paramiko * Up to
(excluding)
2.4.1-r0
运行在以下环境
系统 alpine_edge paramiko * Up to
(excluding)
2.4.1-r0
运行在以下环境
系统 amazon_AMI paramiko * Up to
(excluding)
1.15.1-2.6.amzn1
运行在以下环境
系统 centos_6 paramiko * Up to
(excluding)
1.7.5-4.el6_9
运行在以下环境
系统 debian_8 paramiko * Up to
(excluding)
1.15.1-1+deb8u1
运行在以下环境
系统 debian_9 paramiko * Up to
(excluding)
2.0.0-1+deb9u1
运行在以下环境
系统 fedora_26 paramiko * Up to
(excluding)
2.2.3-1.fc26
运行在以下环境
系统 fedora_27 paramiko * Up to
(excluding)
2.3.2-1.fc27
运行在以下环境
系统 fedora_28 paramiko * Up to
(excluding)
2.4.1-1.fc28
运行在以下环境
系统 fedora_EPEL_7 paramiko * Up to
(excluding)
2.1.1-0.4.el7
运行在以下环境
系统 opensuse_Leap_42.3 paramiko * Up to
(excluding)
2.0.8-4.3.1
运行在以下环境
系统 oracle_6 paramiko * Up to
(excluding)
1.7.5-4.el6_9
运行在以下环境
系统 ubuntu_14.04 paramiko * Up to
(excluding)
1.10.1-1git1ubuntu0.1
运行在以下环境
系统 ubuntu_16.04 paramiko * Up to
(excluding)
1.16.0-1ubuntu0.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-287 认证机制不恰当
阿里云安全产品覆盖情况