中危 Apache Axis 1.0./1.1/1.2/1.3/1.4 跨站脚本攻击

CVE编号

CVE-2018-8032

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-08-03
漏洞描述
Apache Axis是美国阿帕奇(Apache)软件基金会的一个开源、基于XML的Web服务架构,它包含了Java和C++语言实现的SOAP服务器,以及各种公用服务及API,以生成和部署Web服务应用。

Apache Axis 1.x版本至1.4版本中默认的servlet/services存在跨站脚本漏洞。远程攻击者可利用该漏洞注入任意的Web脚本或HTML。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://travis-ci.org/apache/axis1-java
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache axis * From
(including)
1.0
Up to
(including)
1.4
运行在以下环境
系统 debian_9 axis * Up to
(excluding)
1.4-25+deb9u1
运行在以下环境
系统 fedora_27 axis * Up to
(excluding)
1.4-35.fc27
运行在以下环境
系统 opensuse_Leap_15.0 axis * Up to
(excluding)
1.4-lp150.4.3.1
运行在以下环境
系统 opensuse_Leap_42.3 axis * Up to
(excluding)
1.4-295.3.1
运行在以下环境
系统 sles_11_SP4 axis * Up to
(excluding)
1.4-236.236.44.9.1
运行在以下环境
系统 sles_12 axis * Up to
(excluding)
1.4-290.3
运行在以下环境
系统 sles_12_SP3 axis * Up to
(excluding)
1.4-290.3.1
运行在以下环境
系统 suse_11_SP4 axis * Up to
(excluding)
1.4-236.236.44.9.1
运行在以下环境
系统 suse_12 axis * Up to
(excluding)
1.4-290.3
运行在以下环境
系统 suse_12_SP3 axis * Up to
(excluding)
1.4-290.3.1
阿里云评分
4.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况