低危 Jupyter Notebook up to 5.4.0 Notebook File 跨站脚本攻击

CVE编号

CVE-2018-8768

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-03-18
漏洞描述
Jupyter Notebook是一套用于创建、共享代码和说明性文本文档的开源Web应用程序。

Jupyter Notebook 5.4.1之前版本中存在安全漏洞。攻击者可借助恶意伪造的记事本文件利用该漏洞在记事本上下文中执行JavaScript代码。
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
http://openwall.com/lists/oss-security/2018/03/15/2
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 jupyter notebook * Up to
(excluding)
5.4.1
运行在以下环境
系统 debian_9 jupyter-notebook * Up to
(excluding)
4.2.3-4+deb9u1
运行在以下环境
系统 fedora_26 jupyter-notebook * Up to
(excluding)
5.0.0-2.fc26
运行在以下环境
系统 fedora_27 jupyter-notebook * Up to
(excluding)
5.2.1-2.fc27
运行在以下环境
系统 fedora_28 jupyter-notebook * Up to
(excluding)
5.4.0-2.fc28
运行在以下环境
系统 ubuntu_18.04.5_lts jupyter-notebook * Up to
(excluding)
5.4.1-1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
NVD-CWE-noinfo
阿里云安全产品覆盖情况