低危 libxml2 2.9.8 xzlib.c xz_decomp 拒绝服务漏洞

CVE编号

CVE-2018-9251

利用情况

暂无

补丁情况

官方补丁

披露时间

2018-04-04
漏洞描述
libxml2是GNOME项目组所研发的一个基于C语言的用来解析XML文档的函数库,它支持多种编码格式、Xpath解析、Well-formed和valid验证等。

libxml2 2.9.8版本中的xzlib.c文件的‘xz_decomp’函数存在安全漏洞。远程攻击者可借助特制的XML文件利用该漏洞造成拒绝服务(无限循环)。
解决建议
厂商尚未提供漏洞修复方案,请关注厂商主页更新:
http://xmlsoft.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 xmlsoft libxml2 2.9.8 -
运行在以下环境
系统 alpine_3.10 libxml2 * Up to
(excluding)
2.9.8-r1
运行在以下环境
系统 alpine_3.11 libxml2 * Up to
(excluding)
2.9.8-r1
运行在以下环境
系统 alpine_3.12 libxml2 * Up to
(excluding)
2.9.8-r1
运行在以下环境
系统 alpine_3.13 libxml2 * Up to
(excluding)
2.9.8-r1
运行在以下环境
系统 alpine_3.14 libxml2 * Up to
(excluding)
2.9.8-r1
运行在以下环境
系统 alpine_3.15 libxml2 * Up to
(excluding)
2.9.8-r1
运行在以下环境
系统 alpine_3.5 libxml2 * Up to
(excluding)
2.9.8-r1
运行在以下环境
系统 alpine_3.6 libxml2 * Up to
(excluding)
2.9.8-r1
运行在以下环境
系统 alpine_3.7 libxml2 * Up to
(excluding)
2.9.8-r1
运行在以下环境
系统 alpine_3.8 libxml2 * Up to
(excluding)
2.9.8-r1
运行在以下环境
系统 alpine_3.9 libxml2 * Up to
(excluding)
2.9.8-r1
运行在以下环境
系统 alpine_edge libxml2 * Up to
(excluding)
2.9.8-r1
运行在以下环境
系统 centos_8 libxml2 * Up to
(excluding)
2.9.7-7.el8
运行在以下环境
系统 fedora_27 libxml2 * Up to
(excluding)
2.9.8-4.fc27
运行在以下环境
系统 fedora_28 libxml2 * Up to
(excluding)
2.9.8-4.fc28
运行在以下环境
系统 opensuse_Leap_15.0 libxml2 * Up to
(excluding)
2.9.7-lp150.2.3.1
运行在以下环境
系统 opensuse_Leap_42.3 libxml2 * Up to
(excluding)
2.9.4-18.1
运行在以下环境
系统 oracle_8 libxml2 * Up to
(excluding)
2.9.7-7.0.1.el8
运行在以下环境
系统 redhat_8 libxml2 * Up to
(excluding)
2.9.7-7.el8
运行在以下环境
系统 suse_12 libxml2 * Up to
(excluding)
2.9.4-46.15
运行在以下环境
系统 suse_12_SP3 libxml2 * Up to
(excluding)
2.9.4-46.15.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-835 不可达退出条件的循环(无限循环)
阿里云安全产品覆盖情况