严重 Apache Solr jmx.serviceUrl 功能 远程命令执行漏洞

CVE编号

CVE-2019-0192

利用情况

EXP 已公开

补丁情况

官方补丁

披露时间

2019-03-08
该漏洞EXP已公开传播,漏洞利用成本极低,建议您立即关注并修复。
漏洞描述
Apache Solr < 7.0.0 的版本中,允许core ConfigAPI修改jmx.serviceUrl属性,恶意攻击者可将其指向设定好的RMI/LDAP服务,导致反序列化远程代码执行漏洞,使用流行的ysoserial工具即可达到漏洞测试效果。
解决建议
下载相关补丁
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache solr * From
(including)
5.0.0
Up to
(including)
5.5.5
运行在以下环境
应用 apache solr * From
(including)
6.0.0
Up to
(including)
6.6.5
运行在以下环境
应用 netapp storage_automation_store - -
阿里云评分
9.4
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    全局影响
  • EXP成熟度
    EXP 已公开
  • 补丁情况
    官方补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    服务器失陷
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-502 可信数据的反序列化
阿里云安全产品覆盖情况