低危 mod_auth_digest:由于竞争条件导致的访问控制旁路

CVE编号

CVE-2019-0217

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-04-09
漏洞描述
当Web服务器在线程MPM配置中运行时,在mod_auth_digest中找到了竞争条件。它可以允许具有有效凭据的用户使用其他用户名进行身份验证,从而绕过已配置的访问控制限制。

解决建议
用户可参考如下供应商提供的安全公告获得补丁信息:
https://httpd.apache.org/security/vulnerabilities_24.html
参考链接
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00051.html
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00061.html
http://lists.opensuse.org/opensuse-security-announce/2019-04/msg00084.html
http://www.openwall.com/lists/oss-security/2019/04/02/5
http://www.securityfocus.com/bid/107668
https://access.redhat.com/errata/RHSA-2019:2343
https://access.redhat.com/errata/RHSA-2019:3436
https://access.redhat.com/errata/RHSA-2019:3932
https://access.redhat.com/errata/RHSA-2019:3933
https://access.redhat.com/errata/RHSA-2019:3935
https://access.redhat.com/errata/RHSA-2019:4126
https://bugzilla.redhat.com/show_bug.cgi?id=1695020
https://httpd.apache.org/security/vulnerabilities_24.html
https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e8029...
https://lists.apache.org/thread.html/84a3714f0878781f6ed84473d1a503d2cc382277...
https://lists.apache.org/thread.html/e0b8f6e858b1c8ec2ce8e291a2c543d438915037...
https://lists.apache.org/thread.html/r03ee478b3dda3e381fd6189366fa7af97c980d2...
https://lists.apache.org/thread.html/r06f0d87ebb6d59ed8379633f36f72f5b1f79cad...
https://lists.apache.org/thread.html/r76142b8c5119df2178be7c2dba88fde552eedee...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444a...
https://lists.apache.org/thread.html/rd18c3c43602e66f9cdcf09f1de233804975b957...
https://lists.apache.org/thread.html/rd2fb621142e7fa187cfe12d7137bf66e7234abc...
https://lists.apache.org/thread.html/re3d27b6250aa8548b8845d314bb8a350b3df326...
https://lists.apache.org/thread.html/re473305a65b4db888e3556e4dae10c2a04ee89d...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://lists.debian.org/debian-lts-announce/2019/04/msg00008.html
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://seclists.org/bugtraq/2019/Apr/5
https://security.netapp.com/advisory/ntap-20190423-0001/
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-...
https://usn.ubuntu.com/3937-1/
https://usn.ubuntu.com/3937-2/
https://www.debian.org/security/2019/dsa-4422
https://www.oracle.com/security-alerts/cpuapr2020.html
https://www.oracle.com/technetwork/security-advisory/cpujul2019-5072835.html
https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * From
(including)
2.4.0
Up to
(including)
2.4.38
运行在以下环境
应用 netapp oncommand_unified_manager - -
运行在以下环境
应用 oracle enterprise_manager_ops_center 12.3.3 -
运行在以下环境
应用 oracle enterprise_manager_ops_center 12.4.0 -
运行在以下环境
应用 oracle http_server 12.2.1.3.0 -
运行在以下环境
应用 oracle retail_xstore_point_of_service 7.0 -
运行在以下环境
应用 oracle retail_xstore_point_of_service 7.1 -
运行在以下环境
系统 alibaba_cloud_linux_2.1903 httpd * Up to
(excluding)
2.4.6-90.1.al7
运行在以下环境
系统 alpine_3.10 httpd * Up to
(excluding)
2.4.39-r0
运行在以下环境
系统 alpine_3.11 httpd * Up to
(excluding)
2.4.39-r0
运行在以下环境
系统 alpine_3.12 httpd * Up to
(excluding)
2.4.39-r0
运行在以下环境
系统 alpine_3.13 httpd * Up to
(excluding)
2.4.39-r0
运行在以下环境
系统 alpine_3.14 httpd * Up to
(excluding)
2.4.39-r0
运行在以下环境
系统 alpine_3.15 httpd * Up to
(excluding)
2.4.39-r0
运行在以下环境
系统 alpine_3.6 httpd * Up to
(excluding)
2.4.39-r0
运行在以下环境
系统 alpine_3.7 httpd * Up to
(excluding)
2.4.39-r0
运行在以下环境
系统 alpine_3.8 httpd * Up to
(excluding)
2.4.39-r0
运行在以下环境
系统 alpine_3.9 httpd * Up to
(excluding)
2.4.39-r0
运行在以下环境
系统 alpine_edge httpd * Up to
(excluding)
2.4.39-r0
运行在以下环境
系统 amazon_2 httpd * Up to
(excluding)
2.4.39-1.amzn2.0.1
运行在以下环境
系统 amazon_AMI httpd * Up to
(excluding)
2.4.39-1.87.amzn1
运行在以下环境
系统 centos_7 httpd * Up to
(excluding)
2.4.6-90.el7.centos
运行在以下环境
系统 centos_8 httpd * Up to
(excluding)
2.4.37-16.module+el8.1.0+4134+e6bad0ed
运行在以下环境
系统 debian_8 httpd * Up to
(excluding)
2.4.10-10+deb8u1
运行在以下环境
系统 debian_9 httpd * Up to
(excluding)
2.4.25-3+deb9u7
运行在以下环境
系统 fedora_28 httpd * Up to
(excluding)
2.4.39-1.1.fc28
运行在以下环境
系统 fedora_29 httpd * Up to
(excluding)
2.4.39-2.fc29
运行在以下环境
系统 fedora_30 httpd * Up to
(excluding)
2.4.39-2.fc30
运行在以下环境
系统 opensuse_Leap_15.0 httpd * Up to
(excluding)
2.4.33-lp150.2.17.1
运行在以下环境
系统 opensuse_Leap_42.3 httpd * Up to
(excluding)
2.4.23-45.1
运行在以下环境
系统 oracle_7 httpd * Up to
(excluding)
2.4.6-90.0.1.el7
运行在以下环境
系统 oracle_8 httpd * Up to
(excluding)
1.11.3-3.module+el8.1.0+5385+dcd9ff33
运行在以下环境
系统 redhat_8 httpd * Up to
(excluding)
2.4.37-16.module+el8.1.0+4134+e6bad0ed
运行在以下环境
系统 suse_12_SP3 httpd * Up to
(excluding)
2.4.23-29.40.1
运行在以下环境
系统 suse_12_SP4 httpd * Up to
(excluding)
2.4.23-29.40.1
运行在以下环境
系统 ubuntu_14.04 httpd * Up to
(excluding)
2.4.7-1ubuntu4.22
运行在以下环境
系统 ubuntu_16.04 httpd * Up to
(excluding)
2.4.18-2ubuntu3.10
运行在以下环境
系统 ubuntu_18.04 httpd * Up to
(excluding)
2.4.29-1ubuntu4.6
阿里云评分
2.4
  • 攻击路径
    远程
  • 攻击复杂度
    困难
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-362 使用共享资源的并发执行不恰当同步问题(竞争条件)
阿里云安全产品覆盖情况