低危 Apache HTTP Server 资源管理错误漏洞

CVE编号

CVE-2019-10082

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-09-27
漏洞描述
Apache HTTP Server是美国阿帕奇软件(Apache Software)基金会的一款开源网页服务器。该服务器具有快速、可靠且可通过简单的API进行扩充的特点。
Apache HTTP Server 2.4.18版本至2.4.39版本中的h2连接关闭过程存在资源管理错误漏洞。该漏洞源于网络系统或产品对系统资源(如内存、磁盘空间、文件等)的管理不当。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * From
(including)
2.4.18
Up to
(including)
2.4.39
运行在以下环境
系统 alpine_3.10 apache2 * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.11 apache2 * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.12 apache2 * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.13 apache2 * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.14 apache2 * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.15 apache2 * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.7 apache2 * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.8 apache2 * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.9 apache2 * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_edge apache2 * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 amazon_AMI apache2 * Up to
(excluding)
2.4.41-1.88.amzn1
运行在以下环境
系统 centos_8 apache2 * Up to
(excluding)
2.4.37-30.module+el8.3.0+7001+0766b9e7
运行在以下环境
系统 debian_10 apache2 * Up to
(excluding)
2.4.38-3+deb10u1
运行在以下环境
系统 debian_9 apache2 * Up to
(excluding)
2.4.25-3+deb9u8
运行在以下环境
系统 opensuse_Leap_15.0 apache2 * Up to
(excluding)
2.4.33-lp151.8.6.1
运行在以下环境
系统 opensuse_Leap_15.1 apache2 * Up to
(excluding)
2.4.33-lp151.8.6.1
运行在以下环境
系统 oracle_8 apache2 * Up to
(excluding)
2.4.37-30.0.1.module+el8.3.0+7816+49791cfd
运行在以下环境
系统 redhat_8 apache2 * Up to
(excluding)
2.4.37-30.module+el8.3.0+7001+0766b9e7
运行在以下环境
系统 suse_12_SP4 apache2 * Up to
(excluding)
2.4.23-29.43.1
运行在以下环境
系统 ubuntu_18.04 apache2 * Up to
(excluding)
2.4.29-1ubuntu4.10
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-416 释放后使用
阿里云安全产品覆盖情况