中危 Oracle Secure Global Desktop 5.4/5.5 Web Server 跨站点脚本漏洞

CVE编号

CVE-2019-10092

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-09-27
漏洞描述
Apache httpd是美国阿帕奇(Apache)软件基金会的一款专为现代操作系统开发和维护的开源HTTP服务器。
Apache httpd中的mod_proxy错误页面存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。以下产品及版本受到影响:Apache httpd 2.4.39版本,2.4.38版本,2.4.37版本,2.4.35版本,2.4.34版本,2.4.33版本,2.4.30版本,2.4.29版本,2.4.28版本,2.4.27版本,2.4.26版本,2.4.25版本,2.4.23版本,2.4.20版本,2.4.18版本,2.4.17版本,2.4.16版本,2.4.12版本,2.4.10版本,2.4.9版本,2.4.7版本,2.4.6版本,2.4.4版本,2.4.3版本,2.4.2版本,2.4.1版本,2.4.0版本。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
http://httpd.apache.org/security/vulnerabilities_24.html
参考链接
http://lists.opensuse.org/opensuse-security-announce/2019-09/msg00004.html
http://www.openwall.com/lists/oss-security/2019/08/15/4
http://www.openwall.com/lists/oss-security/2020/08/08/1
http://www.openwall.com/lists/oss-security/2020/08/08/9
https://access.redhat.com/errata/RHSA-2019:4126
https://github.com/DrunkenShells/Disclosures/tree/master/CVE-2019-10092-Limit...
https://httpd.apache.org/security/vulnerabilities_24.html
https://lists.apache.org/thread.html/56c2e7cc9deb1c12a843d0dc251ea7fd3e7e8029...
https://lists.apache.org/thread.html/73768e31e0fcae03e12f5aa87da1cb26dece3932...
https://lists.apache.org/thread.html/r03ee478b3dda3e381fd6189366fa7af97c980d2...
https://lists.apache.org/thread.html/r06f0d87ebb6d59ed8379633f36f72f5b1f79cad...
https://lists.apache.org/thread.html/r0a83b112cd9701ef8a2061c8ed557f3dc9bb774...
https://lists.apache.org/thread.html/r3c5c3104813c1c5508b55564b66546933079250...
https://lists.apache.org/thread.html/r76142b8c5119df2178be7c2dba88fde552eedee...
https://lists.apache.org/thread.html/r9f93cf6dde308d42a9c807784e8102600d0397f...
https://lists.apache.org/thread.html/rc998b18880df98bafaade071346690c2bc1444a...
https://lists.apache.org/thread.html/rd18c3c43602e66f9cdcf09f1de233804975b957...
https://lists.apache.org/thread.html/rd2fb621142e7fa187cfe12d7137bf66e7234abc...
https://lists.apache.org/thread.html/re3d27b6250aa8548b8845d314bb8a350b3df326...
https://lists.apache.org/thread.html/rf6449464fd8b7437704c55f88361b66f12d5b5f...
https://lists.debian.org/debian-lts-announce/2019/08/msg00034.html
https://lists.debian.org/debian-lts-announce/2019/09/msg00034.html
https://lists.fedoraproject.org/archives/list/package-announce@lists.fedorapr...
https://seclists.org/bugtraq/2019/Aug/47
https://seclists.org/bugtraq/2019/Oct/24
https://security.gentoo.org/glsa/201909-04
https://security.netapp.com/advisory/ntap-20190905-0003/
https://support.f5.com/csp/article/K30442259
https://usn.ubuntu.com/4113-1/
https://www.debian.org/security/2019/dsa-4509
https://www.oracle.com/security-alerts/cpuapr2020.html
https://www.oracle.com/security-alerts/cpujan2020.html
https://www.oracle.com/security-alerts/cpujul2020.html
https://www.oracle.com/technetwork/security-advisory/cpuoct2019-5072832.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 apache http_server * From
(including)
2.4.0
Up to
(including)
2.4.39
运行在以下环境
应用 oracle communications_element_manage 8.0.0 -
运行在以下环境
应用 oracle communications_element_manage 8.1.0 -
运行在以下环境
应用 oracle communications_element_manage 8.1.1 -
运行在以下环境
应用 oracle communications_element_manage 8.2.0 -
运行在以下环境
应用 oracle enterprise_manager_ops_center 12.3.3 -
运行在以下环境
应用 oracle enterprise_manager_ops_center 12.4.0 -
运行在以下环境
应用 oracle secure_global_desktop 5.4 -
运行在以下环境
应用 oracle secure_global_desktop 5.5 -
运行在以下环境
应用 redhat software_collection 1.0 -
运行在以下环境
系统 alpine_3.10 httpd * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.11 httpd * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.12 httpd * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.13 httpd * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.14 httpd * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.15 httpd * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.7 httpd * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.8 httpd * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_3.9 httpd * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 alpine_edge httpd * Up to
(excluding)
2.4.41-r0
运行在以下环境
系统 amazon linux_2 httpd * Up to
(excluding)
2.4.41-1.amzn2.0.1
运行在以下环境
系统 amazon linux_AMI httpd * Up to
(excluding)
2.4.41-1.88.amzn1
运行在以下环境
系统 amazon_2 httpd * Up to
(excluding)
2.4.41-1.amzn2.0.1
运行在以下环境
系统 amazon_AMI httpd * Up to
(excluding)
2.4.41-1.88.amzn1
运行在以下环境
系统 canonical ubuntu_linux 16.04 -
运行在以下环境
系统 canonical ubuntu_linux 18.04 -
运行在以下环境
系统 canonical ubuntu_linux 19.04 -
运行在以下环境
系统 centos_8 httpd * Up to
(excluding)
2.4.37-30.module+el8.3.0+7001+0766b9e7
运行在以下环境
系统 debian debian_linux 10.0 -
运行在以下环境
系统 debian debian_linux 8.0 -
运行在以下环境
系统 debian debian_linux 9.0 -
运行在以下环境
系统 debian_10 httpd * Up to
(excluding)
2.4.38-3+deb10u3
运行在以下环境
系统 debian_8 httpd * Up to
(excluding)
2.4.10-10+deb8u1
运行在以下环境
系统 debian_9 httpd * Up to
(excluding)
2.4.25-3+deb9u9
运行在以下环境
系统 fedoraproject fedora 30 -
运行在以下环境
系统 fedora_29 httpd * Up to
(excluding)
2.4.41-1.fc29
运行在以下环境
系统 fedora_30 httpd * Up to
(excluding)
2.4.41-1.fc30
运行在以下环境
系统 netapp clustered_data_ontap * Up to
(including)
9.5
运行在以下环境
系统 netapp clustered_data_ontap 9.6 -
运行在以下环境
系统 opensuse leap 15.0 -
运行在以下环境
系统 opensuse leap 15.1 -
运行在以下环境
系统 opensuse_Leap_15.0 httpd * Up to
(excluding)
2.4.33-lp151.8.6.1
运行在以下环境
系统 opensuse_Leap_15.1 httpd * Up to
(excluding)
2.4.33-lp151.8.6.1
运行在以下环境
系统 oracle linux_8 httpd * Up to
(excluding)
2.4.37-30.0.1.module+el8.3.0+7816+49791cfd
运行在以下环境
系统 oracle_8 httpd * Up to
(excluding)
2.4.37-30.0.1.module+el8.3.0+7816+49791cfd
运行在以下环境
系统 redhat_8 httpd * Up to
(excluding)
2.4.37-30.module+el8.3.0+7001+0766b9e7
运行在以下环境
系统 sles_12 apache2 * Up to
(excluding)
2.4.23-29.43
运行在以下环境
系统 sles_12_SP4 httpd * Up to
(excluding)
2.4.23-29.43.1
运行在以下环境
系统 sles_12_SP5 httpd * Up to
(excluding)
2.4.23-29.69.1
运行在以下环境
系统 suse_12_SP4 httpd * Up to
(excluding)
2.4.23-29.43.1
运行在以下环境
系统 suse_12_SP5 httpd * Up to
(excluding)
2.4.23-29.69.1
运行在以下环境
系统 ubuntu_16.04 httpd * Up to
(excluding)
2.4.18-2ubuntu3.12
运行在以下环境
系统 ubuntu_16.04_lts apache2 * Up to
(excluding)
2.4.18-2ubuntu3.12
运行在以下环境
系统 ubuntu_18.04 httpd * Up to
(excluding)
2.4.29-1ubuntu4.10
运行在以下环境
系统 ubuntu_18.04_lts apache2 * Up to
(excluding)
2.4.29-1ubuntu4.10
阿里云评分
4.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况