低危 拒绝服务漏洞

CVE编号

CVE-2019-1010204

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-07-24
漏洞描述
GNU binutils v1.11-v1.16 (GNU binutils v2.21-v2.31.1)受以下因素影响:输入验证不正确、有符号或者无符号比较、越界读取。其影响是:拒绝服务。组件是:gold/fileread。答:497年,elfcpp / elfcpp_file.h: 644。攻击向量是:必须打开一个包含无效e_shoff头字段的ELF文件。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu binutils * From
(including)
2.21
Up to
(including)
2.31.1
运行在以下环境
应用 gnu binutils_gold * From
(including)
1.11
Up to
(including)
1.16
运行在以下环境
系统 centos_8 binutils * Up to
(excluding)
2.30-73.el8
运行在以下环境
系统 debian_10 binutils * Up to
(excluding)
2.31.1-16
运行在以下环境
系统 debian_11 binutils * Up to
(excluding)
2.35.2-2
运行在以下环境
系统 debian_12 binutils * Up to
(excluding)
2.37-7
运行在以下环境
系统 debian_9 binutils * Up to
(excluding)
2.28-5
运行在以下环境
系统 debian_sid binutils * Up to
(excluding)
2.37-10
运行在以下环境
系统 oracle_8 binutils * Up to
(excluding)
2.30-73.0.1.el8
运行在以下环境
系统 redhat_8 binutils * Up to
(excluding)
2.30-73.el8
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
CWE-20 输入验证不恰当
CWE-681 数值类型间的不正确转换
阿里云安全产品覆盖情况