低危 对返回的模块数据进行不安全的模板评估可能导致信息泄露

CVE编号

CVE-2019-10156

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-07-31 12:15:00
漏洞描述
在2.6.18,2.7.12和2.8.2之前的版本中实现Ansible模板的方式中发现了一个缺陷,导致通过意外的变量替换进行信息泄露的可能性。通过利用非预期的变量替换,可以公开任何变量的内容。<br>
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible * Up to
(excluding)
2.6.18
运行在以下环境
应用 redhat ansible * From
(including)
2.7.0
Up to
(excluding)
2.7.12
运行在以下环境
应用 redhat ansible * From
(including)
2.8.0
Up to
(excluding)
2.8.2
2
运行在以下环境
应用 redhat ceph_storage 2.0 -
运行在以下环境
应用 redhat ceph_storage 3.0 -
运行在以下环境
应用 redhat openstack 10 -
运行在以下环境
应用 redhat openstack 13.0 -
运行在以下环境
应用 redhat openstack 14.0 -
3
运行在以下环境
系统 debian_9 ansible * Up to
(excluding)
2.2.1.0-2+deb9u1
4
运行在以下环境
系统 debian_8 ansible * Up to
(excluding)
1.7.2+dfsg-2+deb8u2
5
运行在以下环境
系统 debian_10 ansible * Up to
(excluding)
2.7.7+dfsg-1
6
运行在以下环境
系统 alpine_3.8 ansible * Up to
(excluding)
2.6.18-r0
7
运行在以下环境
系统 alpine_3.11 ansible * Up to
(excluding)
2.8.2-r0
8
运行在以下环境
系统 alpine_3.12 ansible * Up to
(excluding)
2.8.2-r0
9
运行在以下环境
系统 alpine_3.10 ansible * Up to
(excluding)
2.8.2-r0
10
运行在以下环境
系统 alpine_3.9 ansible * Up to
(excluding)
2.7.12-r0
11
运行在以下环境
系统 alpine_edge ansible * Up to
(excluding)
2.8.2-r0
12
运行在以下环境
系统 alpine_3.13 ansible * Up to
(excluding)
2.8.2-r0
13
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.8.1-1.el7
14
运行在以下环境
系统 fedora_29 ansible * Up to
(excluding)
2.8.1-1.fc29
15
运行在以下环境
系统 fedora_30 ansible * Up to
(excluding)
2.8.1-1.fc30
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-200 信息暴露
阿里云安全产品覆盖情况