低危 pki-core 跨站脚本漏洞

CVE编号

CVE-2019-10179

利用情况

暂无

补丁情况

没有补丁

披露时间

2020-03-21
漏洞描述
pki-core是一款为PKI操作提供API的库。
pki-core 10.x.x版本中存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。

解决建议
厂商尚未提供漏洞修复方案,请关注厂商主页更新:
https://www.redhat.com/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 dogtagpki dogtagpki * From
(including)
10.0
Up to
(including)
10.8.3
运行在以下环境
系统 alibaba_cloud_linux_2.1903 pki-ca * Up to
(excluding)
10.5.18-12.1.al7
运行在以下环境
系统 amazon_2 pki-core * Up to
(excluding)
10.5.18-12.amzn2.0.1
运行在以下环境
系统 centos_7 pki-ca * Up to
(excluding)
10.5.18-12.el7_9
运行在以下环境
系统 debian_11 dogtag-pki * Up to
(excluding)
10.9.1-1
运行在以下环境
系统 oracle_7 pki-ca * Up to
(excluding)
10.5.18-12.el7_9
运行在以下环境
系统 redhat enterprise_linux 7.0 -
运行在以下环境
系统 redhat enterprise_linux 8.0 -
运行在以下环境
系统 redhat_7 pki-ca * Up to
(excluding)
10.5.18-12.el7_9
阿里云评分
3.8
  • 攻击路径
    远程
  • 攻击复杂度
    容易
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    没有补丁
  • 数据保密性
    无影响
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况