低危 在所有pki-core 10.x.x版本中发现一个漏洞

CVE编号

CVE-2019-10180

利用情况

暂无

补丁情况

没有补丁

披露时间

2020-04-01
漏洞描述
在所有pki-core 10.x.x版本中都发现了一个漏洞,在该版本中,令牌处理服务(TPS)未能正确清理为令牌存储的多个参数,可能导致存储跨站点脚本(XSS)漏洞。能够修改任何令牌参数的攻击者可能会利用此缺陷,诱使经过身份验证的用户执行任意JavaScript代码。

解决建议
厂商尚未提供漏洞修复方案,请关注厂商主页更新:
https://www.redhat.com/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 dogtagpki dogtagpki * From
(including)
10.0
Up to
(including)
10.8.3
运行在以下环境
应用 redhat certificate_system 10.0 -
运行在以下环境
系统 debian_11 dogtag-pki * Up to
(including)
10.10.2-3
运行在以下环境
系统 debian_12 dogtag-pki * Up to
(including)
11.0.3-4
运行在以下环境
系统 debian_sid dogtag-pki * Up to
(including)
11.0.3-4
运行在以下环境
系统 oracle_7 dogtag-pki * Up to
(excluding)
10.5.18-12.el7_9
阿里云评分
3.8
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    没有补丁
  • 数据保密性
    数据泄露
  • 数据完整性
    传输被破坏
  • 服务器危害
    无影响
  • 全网数量
    N/A
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况