低危 Ansible 输入验证错误漏洞

CVE编号

CVE-2019-10206

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-11-23 02:15:00
漏洞描述
Ansible是美国Ansible公司的一款计算机系统配置管理器。该产品可用于发布、管理和编排计算机系统。
Ansible 2.8.4之前的2.8.x版本、2.7.13之前的2.7.x版本和2.6.19之前的2.6.x版本中存在输入验证错误漏洞。该漏洞源于网络系统或产品未对输入的数据进行正确的验证。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible * From
(including)
2.6.0
Up to
(excluding)
2.6.19
运行在以下环境
应用 redhat ansible * From
(including)
2.7.0
Up to
(excluding)
2.7.13
运行在以下环境
应用 redhat ansible * From
(including)
2.8.0
Up to
(excluding)
2.8.4
2
运行在以下环境
系统 alpine_3.7 ansible * Up to
(excluding)
2.4.6.0-r1
3
运行在以下环境
系统 debian_9 ansible * Up to
(excluding)
2.2.1.0-2+deb9u1
4
运行在以下环境
系统 debian_10 ansible * Up to
(excluding)
2.7.7+dfsg-1
5
运行在以下环境
系统 alpine_3.8 ansible * Up to
(excluding)
2.6.19-r0
6
运行在以下环境
系统 alpine_3.11 ansible * Up to
(excluding)
2.8.4-r0
7
运行在以下环境
系统 alpine_3.12 ansible * Up to
(excluding)
2.8.4-r0
8
运行在以下环境
系统 alpine_3.10 ansible * Up to
(excluding)
2.8.4-r0
9
运行在以下环境
系统 alpine_3.9 ansible * Up to
(excluding)
2.7.13-r0
10
运行在以下环境
系统 alpine_edge ansible * Up to
(excluding)
2.8.4-r0
11
运行在以下环境
系统 alpine_3.13 ansible * Up to
(excluding)
2.8.4-r0
12
运行在以下环境
系统 fedora_30 ansible * Up to
(excluding)
2.8.4-1.fc30
13
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.8.4-1.el7
14
运行在以下环境
系统 fedora_EPEL_8 ansible * Up to
(excluding)
2.9.3-1.el8
15
运行在以下环境
系统 opensuse_Leap_15.1 ansible * Up to
(excluding)
2.9.6-lp151.2.7.1
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-20 输入验证不恰当
阿里云安全产品覆盖情况