低危 MagickCore / locale.c中函数LocaleLowercase中的越界访问导致SIGSEGV

CVE编号

CVE-2019-10714

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-04-03
漏洞描述
在7.0.8-32之前的ImageMagick中的MagickCore / locale.c中的LocaleLowercase允许越界访问,从而导致SIGSEGV。<br>
解决建议
厂商已发布漏洞修复程序,请及时关注更新:
https://www.imagemagick.org/download/beta/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 imagemagick imagemagick * Up to
(excluding)
7.0.8-32
运行在以下环境
系统 fedora_EPEL_7 GraphicsMagick * Up to
(excluding)
1.3.34-1.el7
运行在以下环境
系统 fedora_EPEL_7 GraphicsMagick-c++ * Up to
(excluding)
1.3.34-1.el7
运行在以下环境
系统 fedora_EPEL_7 GraphicsMagick-c++-devel * Up to
(excluding)
1.3.34-1.el7
运行在以下环境
系统 fedora_EPEL_7 GraphicsMagick-debuginfo * Up to
(excluding)
1.3.34-1.el7
运行在以下环境
系统 fedora_EPEL_7 GraphicsMagick-devel * Up to
(excluding)
1.3.34-1.el7
运行在以下环境
系统 fedora_EPEL_7 GraphicsMagick-doc * Up to
(excluding)
1.3.34-1.el7
运行在以下环境
系统 fedora_EPEL_7 GraphicsMagick-perl * Up to
(excluding)
1.3.34-1.el7
运行在以下环境
系统 fedora_EPEL_8 GraphicsMagick * Up to
(excluding)
1.3.34-1.el8
运行在以下环境
系统 fedora_EPEL_8 GraphicsMagick-c++ * Up to
(excluding)
1.3.34-1.el8
运行在以下环境
系统 fedora_EPEL_8 GraphicsMagick-c++-devel * Up to
(excluding)
1.3.34-1.el8
运行在以下环境
系统 fedora_EPEL_8 GraphicsMagick-debuginfo * Up to
(excluding)
1.3.34-1.el8
运行在以下环境
系统 fedora_EPEL_8 GraphicsMagick-devel * Up to
(excluding)
1.3.34-1.el8
运行在以下环境
系统 fedora_EPEL_8 GraphicsMagick-doc * Up to
(excluding)
1.3.34-1.el8
运行在以下环境
系统 fedora_EPEL_8 GraphicsMagick-perl * Up to
(excluding)
1.3.34-1.el8
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况