低危 AngularJS 输入验证错误漏洞

CVE编号

CVE-2019-10768

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-11-20
漏洞描述
AngularJS是一款基于TypeScript的开源Web应用程序框架。
AngularJS 1.7.9之前版本中存在安全漏洞。攻击者可借助‘merge()’函数利用该漏洞实施原型污染攻击。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/angular/angular.js/commit/add78e62004e80bb1e16ab2dfe224afa8e513bc3
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 angularjs angular.js * Up to
(excluding)
1.7.9
运行在以下环境
系统 debian_10 angular.js * Up to
(including)
1.5.10-1
运行在以下环境
系统 debian_9 angular.js * Up to
(including)
1.5.10-1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-1321 Improperly Controlled Modification of Object Prototype Attributes ('Prototype Pollution')
CWE-20 输入验证不恰当
CWE-915 动态确定对象属性修改的控制不恰当
阿里云安全产品覆盖情况