低危 GraphicsMagick 1.4 snapshot-20190322 Q8 coders/svg.c SVGStartElement 内存破坏漏洞

CVE编号

CVE-2019-11005

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-04-09
漏洞描述
在GraphicsMagick 1.4 snapshot-20190322 Q8中,coders / svg.c的函数SVGStartElement中存在基于堆栈的缓冲区溢出,这允许远程攻击者导致拒绝服务(应用程序崩溃)或可能通过引用导致未指定的其他影响字体系列值。<br>
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 graphicsmagick graphicsmagick * Up to
(including)
1.3.31
运行在以下环境
系统 debian_9 graphicsmagick * Up to
(excluding)
1.3.30+hg15796-1~deb9u3
运行在以下环境
系统 fedora_EPEL_7 graphicsmagick * Up to
(excluding)
1.3.34-1.el7
运行在以下环境
系统 fedora_EPEL_8 graphicsmagick * Up to
(excluding)
1.3.34-1.el8
运行在以下环境
系统 opensuse_Leap_15.0 graphicsmagick * Up to
(excluding)
1.3.29-lp150.3.25.1
运行在以下环境
系统 opensuse_Leap_42.3 graphicsmagick * Up to
(excluding)
1.3.29-lp150.3.25.1
运行在以下环境
系统 ubuntu_18.04 graphicsmagick * Up to
(excluding)
1.3.28-2ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts graphicsmagick * Up to
(excluding)
1.3.28-2ubuntu0.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况