低危 函数exif_iif_add_value中的堆缓冲区溢出

CVE编号

CVE-2019-11035

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-04-19
漏洞描述
处理某些文件时,可能会导致7.1.2.8以下版本7.1.x中的 PHP EXIF extension,7.2.17下面的7.2.x和7.3.4下面的7.3.x中的 PHP EXIF extension读取exif_iif_add_value函数中的过去分配的缓冲区。这可能会导致信息泄露或崩溃。

解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 netapp storage_automation_store - -
运行在以下环境
应用 php php * From
(including)
7.1.0
Up to
(excluding)
7.1.28
运行在以下环境
应用 php php * From
(including)
7.2.9
Up to
(excluding)
7.2.17
运行在以下环境
应用 php php * From
(including)
7.3.0
Up to
(excluding)
7.3.4
运行在以下环境
应用 redhat software_collections 1.0 -
运行在以下环境
系统 alpine_3.10 php7 * Up to
(excluding)
7.2.17-r0
运行在以下环境
系统 alpine_3.11 php7 * Up to
(excluding)
7.2.17-r0
运行在以下环境
系统 alpine_3.12 php7 * Up to
(excluding)
7.2.17-r0
运行在以下环境
系统 alpine_3.13 php7 * Up to
(excluding)
7.2.17-r0
运行在以下环境
系统 alpine_3.14 php7 * Up to
(excluding)
7.2.17-r0
运行在以下环境
系统 alpine_3.15 php7 * Up to
(excluding)
7.2.17-r0
运行在以下环境
系统 alpine_3.7 php7 * Up to
(excluding)
7.1.29-r0
运行在以下环境
系统 alpine_3.8 php7 * Up to
(excluding)
7.2.17-r0
运行在以下环境
系统 alpine_3.9 php7 * Up to
(excluding)
7.2.17-r0
运行在以下环境
系统 alpine_edge php7 * Up to
(excluding)
7.2.17-r0
运行在以下环境
系统 amazon_AMI php7 * Up to
(excluding)
7.1.29-1.39.amzn1
运行在以下环境
系统 centos_8 php7 * Up to
(excluding)
5.1.12-2.module+el8.1.0+3202+af5476b9
运行在以下环境
系统 debian_8 php7 * Up to
(excluding)
5.6.20+dfsg-0+deb8u1
运行在以下环境
系统 debian_9 php7 * Up to
(excluding)
7.0.33-0+deb9u5
运行在以下环境
系统 opensuse_Leap_15.0 php7 * Up to
(excluding)
7.2.5-lp150.2.19.1
运行在以下环境
系统 opensuse_Leap_15.1 php7 * Up to
(excluding)
7.2.5-lp151.6.3.1
运行在以下环境
系统 opensuse_Leap_42.3 php7 * Up to
(excluding)
5.5.14-118.1
运行在以下环境
系统 oracle_8 php7 * Up to
(excluding)
7.2.24-1.module+el8.2.0+5510+6771133c
运行在以下环境
系统 redhat_8 php7 * Up to
(excluding)
5.1.12-2.module+el8.1.0+3202+af5476b9
运行在以下环境
系统 ubuntu_14.04 php7 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.29+esm1
运行在以下环境
系统 ubuntu_16.04 php7 * Up to
(excluding)
7.0.33-0ubuntu0.16.04.4
运行在以下环境
系统 ubuntu_18.04 php7 * Up to
(excluding)
7.2.17-0ubuntu0.18.04.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况