低危 PHP GD Graphics Library 输入验证错误漏洞

CVE编号

CVE-2019-11038

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-06-19
漏洞描述
<br>PHP(PHP:Hypertext Preprocessor,PHP:超文本预处理器)是PHPGroup和开放源代码社区的共同维护的一种开源的通用计算机脚本语言。该语言主要用于Web开发,支持多种数据库及操作系统。GD Graphics Library是使用在其中的一个开源的用于动态创建图像的库。PHP中的GD Graphics Library 2.2.5版本的\'\'gdImageCreateFromXbm()\'\'函数存在输入验证错误漏洞。攻击者可利用该漏洞获取栈中的内容。以下产品及版本受到影响:PHP 7.1.30之前的7.1.x版本,7.2.19之前的7.2.x版本,7.3.6之前的7.3.x版本。
解决建议
目前厂商已发布升级补丁以修复漏洞,详情请关注厂商主页:
https://www.keycloak.org/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 libgd libgd 2.2.5 -
运行在以下环境
应用 php php * From
(including)
7.1.0
Up to
(excluding)
7.1.30
运行在以下环境
应用 php php * From
(including)
7.2.0
Up to
(excluding)
7.2.19
运行在以下环境
应用 php php * From
(including)
7.3.0
Up to
(excluding)
7.3.6
运行在以下环境
应用 redhat software_collections 1.0 -
运行在以下环境
应用 suse linux_enterprise_debuginfo 11 -
运行在以下环境
系统 alpine_3.10 gd * Up to
(excluding)
2.2.5-r3
运行在以下环境
系统 alpine_3.11 gd * Up to
(excluding)
2.2.5-r3
运行在以下环境
系统 alpine_3.12 gd * Up to
(excluding)
2.3.0-r0
运行在以下环境
系统 alpine_3.13 gd * Up to
(excluding)
2.3.0-r0
运行在以下环境
系统 alpine_3.14 gd * Up to
(excluding)
2.3.0-r0
运行在以下环境
系统 alpine_3.15 gd * Up to
(excluding)
2.3.0-r0
运行在以下环境
系统 alpine_3.16 gd * Up to
(excluding)
2.3.0-r0
运行在以下环境
系统 alpine_3.7 gd * Up to
(excluding)
7.1.30-r0
运行在以下环境
系统 alpine_3.8 gd * Up to
(excluding)
2.2.5-r3
运行在以下环境
系统 alpine_3.9 gd * Up to
(excluding)
2.2.5-r3
运行在以下环境
系统 alpine_edge gd * Up to
(excluding)
2.3.0-r0
运行在以下环境
系统 amazon_AMI gd * Up to
(excluding)
7.3.6-1.17.amzn1
运行在以下环境
系统 debian_8 gd * Up to
(excluding)
2.1.0-5+deb8u9
运行在以下环境
系统 debian_9 gd * Up to
(excluding)
7.0.33-0+deb9u5
运行在以下环境
系统 fedora_29 gd * Up to
(excluding)
7.2.19-2.fc29
运行在以下环境
系统 fedora_30 gd * Up to
(excluding)
7.3.6-1.fc30
运行在以下环境
系统 fedora_32 gd * Up to
(excluding)
2.3.0-1.fc32
运行在以下环境
系统 opensuse_Leap_15.1 gd * Up to
(excluding)
2.2.5-lp151.6.6.1
运行在以下环境
系统 suse_12 gd * Up to
(excluding)
2.1.0-24.17
运行在以下环境
系统 suse_12_SP4 gd * Up to
(excluding)
2.1.0-24.17.1
运行在以下环境
系统 suse_12_SP5 gd * Up to
(excluding)
2.1.0-24.17.1
运行在以下环境
系统 ubuntu_14.04 gd * Up to
(excluding)
2.1.0-3ubuntu0.11+esm1
运行在以下环境
系统 ubuntu_14.04.6_lts libgd2 * Up to
(excluding)
2.1.0-3ubuntu0.11+esm1
运行在以下环境
系统 ubuntu_16.04 gd * Up to
(excluding)
2.1.1-4ubuntu0.16.04.12
运行在以下环境
系统 ubuntu_16.04.7_lts libgd2 * Up to
(excluding)
2.1.1-4ubuntu0.16.04.12
运行在以下环境
系统 ubuntu_18.04 gd * Up to
(excluding)
2.2.5-4ubuntu0.4
运行在以下环境
系统 ubuntu_18.04.5_lts libgd2 * Up to
(excluding)
2.2.5-4ubuntu0.4
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-908 对未经初始化资源的使用
阿里云安全产品覆盖情况