低危 php: exif_read_data()中的缓冲区过度读取

CVE编号

CVE-2019-11040

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-06-19
漏洞描述
当PHPEXIF扩展在解析EXIF信息时,例如通过EXIF_READ_DATA()函数,在PHP版本7.1.x下7.7.30、7.7.x下7.19.19和7.7.3x以下7.3.6,可以将其与数据一起提供,从而使其读取经过分配的缓冲区。这可能导致信息披露或崩溃。 

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://bugs.php.net/bug.php?id=77988
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 php php * From
(including)
7.1.0
Up to
(excluding)
7.1.30
运行在以下环境
应用 php php * From
(including)
7.2.0
Up to
(excluding)
7.2.19
运行在以下环境
应用 php php * From
(including)
7.3.0
Up to
(excluding)
7.3.6
运行在以下环境
应用 redhat software_collections 1.0 -
运行在以下环境
系统 alpine_3.10 php7 * Up to
(excluding)
7.2.19-r0
运行在以下环境
系统 alpine_3.11 php7 * Up to
(excluding)
7.2.19-r0
运行在以下环境
系统 alpine_3.12 php7 * Up to
(excluding)
7.2.19-r0
运行在以下环境
系统 alpine_3.13 php7 * Up to
(excluding)
7.2.19-r0
运行在以下环境
系统 alpine_3.14 php * Up to
(excluding)
7.2.19-r0
运行在以下环境
系统 alpine_3.15 php * Up to
(excluding)
7.2.19-r0
运行在以下环境
系统 alpine_3.7 php7 * Up to
(excluding)
7.1.30-r0
运行在以下环境
系统 alpine_3.8 php7 * Up to
(excluding)
7.2.21-r0
运行在以下环境
系统 alpine_3.9 php7 * Up to
(excluding)
7.2.19-r0
运行在以下环境
系统 alpine_edge php7 * Up to
(excluding)
7.2.19-r0
运行在以下环境
系统 amazon_AMI php7 * Up to
(excluding)
7.3.6-1.17.amzn1
运行在以下环境
系统 centos_8 php * Up to
(excluding)
5.1.12-2.module+el8.1.0+3202+af5476b9
运行在以下环境
系统 debian_10 php7 * Up to
(excluding)
7.3.9-1~deb10u1
运行在以下环境
系统 debian_8 php7 * Up to
(excluding)
5.6.20+dfsg-0+deb8u1
运行在以下环境
系统 debian_9 php7 * Up to
(excluding)
7.0.33-0+deb9u5
运行在以下环境
系统 fedora_29 php7 * Up to
(excluding)
7.2.19-2.fc29
运行在以下环境
系统 fedora_30 php7 * Up to
(excluding)
7.3.6-1.fc30
运行在以下环境
系统 opensuse_Leap_15.0 php7 * Up to
(excluding)
7.2.5-lp151.6.6.1
运行在以下环境
系统 opensuse_Leap_15.1 php7 * Up to
(excluding)
7.2.5-lp151.6.6.1
运行在以下环境
系统 oracle_8 php7 * Up to
(excluding)
1.5.2-1.module+el8.2.0+5569+98c8b30d
运行在以下环境
系统 redhat_8 php * Up to
(excluding)
5.1.12-2.module+el8.1.0+3202+af5476b9
运行在以下环境
系统 suse_12 apache2-mod_php5 * Up to
(excluding)
5.5.14-109.63
运行在以下环境
系统 ubuntu_14.04 php * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.29+esm3
运行在以下环境
系统 ubuntu_14.04.6_lts php5 * Up to
(excluding)
5.5.9+dfsg-1ubuntu4.29+esm3
运行在以下环境
系统 ubuntu_16.04 php * Up to
(excluding)
7.0.33-0ubuntu0.16.04.5
运行在以下环境
系统 ubuntu_16.04.7_lts php7.0 * Up to
(excluding)
7.0.33-0ubuntu0.16.04.5
运行在以下环境
系统 ubuntu_18.04 php * Up to
(excluding)
7.2.19-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts php7.2 * Up to
(excluding)
7.2.19-0ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.10 php7.2 * Up to
(excluding)
7.2.19-0ubuntu0.18.10.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-125 跨界内存读
阿里云安全产品覆盖情况