低危 atftp 0.7.1 tftpd_file.c Crafted Packet 内存破坏漏洞

CVE编号

CVE-2019-11365

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-04-21
漏洞描述
atftp是一款TFTP协议的客户端实现。
atftp 0.7.1版本中存在缓冲区错误漏洞。该漏洞源于网络系统或产品在内存上执行操作时,未正确验证数据边界,导致向关联的其他内存位置上执行了错误的读写操作。攻击者可利用该漏洞导致缓冲区溢出或堆溢出等。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://sourceforge.net/p/atftp/code/ci/abed7d245d8e8bdfeab24f9f7f55a52c3140f96b/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 atftp_project atftp 0.7.1 -
运行在以下环境
系统 debian_8 atftp * Up to
(excluding)
0.7.git20120829-1+deb8u1
运行在以下环境
系统 debian_9 atftp * Up to
(excluding)
0.7.git20120829-3.1~deb9u1
运行在以下环境
系统 suse_12 atftp * Up to
(excluding)
0.7.0-160.8
运行在以下环境
系统 suse_12_SP3 atftp * Up to
(excluding)
0.7.0-160.8.1
运行在以下环境
系统 suse_12_SP4 atftp * Up to
(excluding)
0.7.0-160.8.1
运行在以下环境
系统 ubuntu_16.04 atftp * Up to
(excluding)
0.7.20120829-3.1~0.16.04.1
运行在以下环境
系统 ubuntu_16.04.7_lts atftp * Up to
(excluding)
0.7.20120829-3.1~0.16.04.1
运行在以下环境
系统 ubuntu_18.04 atftp * Up to
(excluding)
0.7.20120829-3.1~0.18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts atftp * Up to
(excluding)
0.7.20120829-3.1~0.18.04.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况