低危 graphicsmagick 拒绝服务漏洞

CVE编号

CVE-2019-11505

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-04-25
漏洞描述
在从版本1.3.8到1.4版本的快照-20190403 Q8的GraphicsMagick中,coders / pdb.c的函数WritePDBImage中存在基于堆的缓冲区溢出,这允许攻击者导致拒绝服务或可能通过未指定的其他影响精心制作的图像文件。这与magick / bit_stream.c中的MagickBitStreamMSBWrite有关。<br>
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 graphicsmagick graphicsmagick * From
(including)
1.3.8
Up to
(including)
1.3.31
运行在以下环境
系统 debian_8 graphicsmagick * Up to
(excluding)
1.3.20-3+deb8u2
运行在以下环境
系统 debian_9 graphicsmagick * Up to
(excluding)
1.3.30+hg15796-1~deb9u3
运行在以下环境
系统 opensuse_Leap_15.0 graphicsmagick * Up to
(excluding)
1.3.29-lp150.3.28.1
运行在以下环境
系统 opensuse_Leap_15.1 graphicsmagick * Up to
(excluding)
7.0.7.34-lp151.7.3.1
运行在以下环境
系统 opensuse_Leap_42.3 graphicsmagick * Up to
(excluding)
12-1.3.25-135.1
运行在以下环境
系统 suse_12 ImageMagick * Up to
(excluding)
6.8.8.1-71.123
运行在以下环境
系统 suse_12_SP3 graphicsmagick * Up to
(excluding)
6.8.8.1-71.123.2
运行在以下环境
系统 suse_12_SP4 graphicsmagick * Up to
(excluding)
6.8.8.1-71.123.2
运行在以下环境
系统 ubuntu_18.04 graphicsmagick * Up to
(excluding)
1.3.28-2ubuntu0.1
运行在以下环境
系统 ubuntu_18.04.5_lts graphicsmagick * Up to
(excluding)
1.3.28-2ubuntu0.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况