低危 bzip2:在函数BZ2_decompress中写入越界

CVE编号

CVE-2019-12900

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-06-20 12:15:00
漏洞描述
BZ2_decompress在bzip2 through 1.0.6 的decompress.c上,当有很多选择器时,有一个越界写入。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://gitlab.com/federicomenaquintero/bzip2/commit/74de1e2e6ffc9d51ef9824db71a8ffee5962cdbc
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 bzip bzip2 * Up to
(including)
1.0.6
运行在以下环境
系统 alpine_3.10 bzip2 * Up to
(excluding)
1.0.6-r7
运行在以下环境
系统 alpine_3.11 bzip2 * Up to
(excluding)
1.0.6-r7
运行在以下环境
系统 alpine_3.12 bzip2 * Up to
(excluding)
1.0.6-r7
运行在以下环境
系统 alpine_3.13 bzip2 * Up to
(excluding)
1.0.6-r7
运行在以下环境
系统 alpine_3.14 bzip2 * Up to
(excluding)
1.0.6-r7
运行在以下环境
系统 alpine_3.15 bzip2 * Up to
(excluding)
1.0.6-r7
运行在以下环境
系统 alpine_3.7 bzip2 * Up to
(excluding)
1.0.6-r7
运行在以下环境
系统 alpine_3.8 bzip2 * Up to
(excluding)
1.0.6-r7
运行在以下环境
系统 alpine_3.9 bzip2 * Up to
(excluding)
1.0.6-r7
运行在以下环境
系统 alpine_edge bzip2 * Up to
(excluding)
1.0.6-r7
运行在以下环境
系统 amazon_2 bzip2 * Up to
(excluding)
1.0.6-13.amzn2.0.3
运行在以下环境
系统 debian_10 bzip2 * Up to
(excluding)
0.101.4+dfsg-0+deb10u1
运行在以下环境
系统 debian_8 bzip2 * Up to
(excluding)
1.0.6-7+deb8u1
运行在以下环境
系统 debian_9 bzip2 * Up to
(excluding)
1.0.6-8.1
运行在以下环境
系统 fedora_29 bzip2 * Up to
(excluding)
0.101.4-1.fc29
运行在以下环境
系统 fedora_30 bzip2 * Up to
(excluding)
0.101.4-1.fc30
运行在以下环境
系统 fedora_EPEL_7 bzip2 * Up to
(excluding)
0.101.4-1.el7
运行在以下环境
系统 fedora_EPEL_8 bzip2 * Up to
(excluding)
0.101.4-1.el8
运行在以下环境
系统 opensuse_Leap_15.0 bzip2 * Up to
(excluding)
0.100.3-lp150.2.13.1
运行在以下环境
系统 opensuse_Leap_15.1 bzip2 * Up to
(excluding)
0.100.3-lp151.2.3.1
运行在以下环境
系统 suse_12_SP4 bzip2 * Up to
(excluding)
0.100.3-33.26.1
运行在以下环境
系统 suse_12_SP5 bzip2 * Up to
(excluding)
0.103.0-3.3.1
运行在以下环境
系统 ubuntu_14.04 bzip2 * Up to
(excluding)
1.0.6-5ubuntu0.1~esm2
运行在以下环境
系统 ubuntu_16.04 bzip2 * Up to
(excluding)
0.101.4+dfsg-0ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04 bzip2 * Up to
(excluding)
0.101.4+dfsg-0ubuntu0.18.04.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况