低危 在1.3.32之前的GraphicsMagick中,文本文件名组件允许远程攻击者读取任意文件

CVE编号

CVE-2019-12921

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-03-19
漏洞描述
在1.3.32之前的GraphicsMagick中,由于TranslateTextEx for SVG,文本文件名组件使远程攻击者可以通过精心制作的图像读取任意文件。

解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/d0ge/data-processing/blob/master/CVE-2019-12921.md
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 graphicsmagick graphicsmagick * Up to
(excluding)
1.3.32
运行在以下环境
系统 alpine_3.11 graphicsmagick * Up to
(excluding)
1.3.32-r0
运行在以下环境
系统 alpine_3.12 graphicsmagick * Up to
(excluding)
1.3.32-r0
运行在以下环境
系统 alpine_3.13 graphicsmagick * Up to
(excluding)
1.3.32-r0
运行在以下环境
系统 alpine_3.14 graphicsmagick * Up to
(excluding)
1.3.32-r0
运行在以下环境
系统 alpine_3.15 graphicsmagick * Up to
(excluding)
1.3.32-r0
运行在以下环境
系统 alpine_3.16 graphicsmagick * Up to
(excluding)
1.3.32-r0
运行在以下环境
系统 alpine_edge graphicsmagick * Up to
(excluding)
1.3.32-r0
运行在以下环境
系统 debian_10 graphicsmagick * Up to
(excluding)
1.4+really1.3.35-1~deb10u1
运行在以下环境
系统 debian_8 graphicsmagick * Up to
(excluding)
1.3.20-3+deb8u2
运行在以下环境
系统 debian_9 graphicsmagick * Up to
(excluding)
1.3.30+hg15796-1~deb9u4
运行在以下环境
系统 opensuse_Leap_15.1 graphicsmagick * Up to
(excluding)
1.3.29-lp151.4.17.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-200 信息暴露
CWE-77 在命令中使用的特殊元素转义处理不恰当(命令注入)
阿里云安全产品覆盖情况