低危 Audio File Library 0.3.6 G711.cpp ulaw2linear_buf 拒绝服务漏洞

CVE编号

CVE-2019-13147

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-07-02
漏洞描述
在Audio File Library (audiofile) 0.3.6中,在libmodules的G711.cpp中的ulaw2linear_buf中存在一个空指针dereference错误。允许攻击者通过一个精心设计的文件来导致拒绝服务。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 audio_file_library_project audio_file_library 0.3.6 -
运行在以下环境
系统 debian_10 audiofile * Up to
(including)
0.3.6-5
运行在以下环境
系统 debian_11 audiofile * Up to
(including)
0.3.6-5
运行在以下环境
系统 debian_12 audiofile * Up to
(including)
0.3.6-5
运行在以下环境
系统 debian_9 audiofile * Up to
(including)
0.3.6-4+deb9u1
运行在以下环境
系统 debian_sid audiofile * Up to
(including)
0.3.6-5
运行在以下环境
系统 ubuntu_18.04.5_lts audiofile * Up to
(excluding)
2021-06-29
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-476 空指针解引用
阿里云安全产品覆盖情况