低危 GNU libiberty simple-object-elf.c simple_object_elf_match shstrndx 整数溢出漏洞

CVE编号

CVE-2019-14250

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-07-24
漏洞描述
在GNU libiberty中发现了一个问题,在GNU Binutils 2.32中分发。 simple-object-elf.c中的simple_object_elf_match不会检查零shstrndx值,从而导致整数溢出并导致基于堆的缓冲区溢出。<br>
解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://gcc.gnu.org/ml/gcc-patches/2019-07/msg01003.html
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 gnu binutils 2.32 -
运行在以下环境
系统 debian_10 binutils * Up to
(excluding)
2.31.1-16
运行在以下环境
系统 debian_9 binutils * Up to
(excluding)
2.28-5
运行在以下环境
系统 opensuse_Leap_15.0 binutils * Up to
(excluding)
7.4.1
运行在以下环境
系统 opensuse_Leap_15.1 binutils * Up to
(excluding)
7.4.1
运行在以下环境
系统 opensuse_Leap_15.2 binutils * Up to
(excluding)
2.35-lp152.4.3.1
运行在以下环境
系统 suse_12_SP4 binutils * Up to
(excluding)
9.2.1
运行在以下环境
系统 suse_12_SP5 binutils * Up to
(excluding)
9.2.1
运行在以下环境
系统 ubuntu_16.04 binutils * Up to
(excluding)
2.26.1-1ubuntu1~16.04.8+esm1
运行在以下环境
系统 ubuntu_18.04 binutils * Up to
(excluding)
20170913-1ubuntu0.1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
CWE-787 跨界内存写
阿里云安全产品覆盖情况