低危 拒绝服务漏洞

CVE编号

CVE-2019-14295

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-07-28
漏洞描述
在UPX3.95中的getElf部分函数中的Integer溢出的Integer溢出允许远程攻击者通过大于UPX打包的可执行文件中PE部分大小的倾斜偏移来导致拒绝服务(崩溃),从而触发过多内存的分配。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 upx_project upx 3.95 -
运行在以下环境
系统 debian_10 upx-ucl * Up to
(excluding)
3.95-1
运行在以下环境
系统 debian_9 upx-ucl * Up to
(excluding)
3.91-4
运行在以下环境
系统 fedora_29 upx-ucl * Up to
(excluding)
3.95-4.fc29
运行在以下环境
系统 fedora_30 upx-ucl * Up to
(excluding)
3.95-4.fc30
运行在以下环境
系统 fedora_EPEL_7 upx-ucl * Up to
(excluding)
3.95-4.el7
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-190 整数溢出或超界折返
阿里云安全产品覆盖情况