低危 拒绝服务漏洞

CVE编号

CVE-2019-14296

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-07-28
漏洞描述
UPX 3.95中的p_vmlinx.cpp中的canUnpack允许远程攻击者通过精心设计的UPX打包文件导致拒绝服务(SEGV或缓冲区溢出,应用程序崩溃)或可能具有未指定的其他影响。<br>
解决建议
目前厂商已发布升级补丁以修复漏洞,补丁获取链接:
https://github.com/upx/upx/issues/287
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 upx_project upx 3.95 -
运行在以下环境
系统 alpine_3.12 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_3.13 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_3.14 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_3.15 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_3.16 upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 alpine_edge upx * Up to
(excluding)
3.96-r0
运行在以下环境
系统 debian_10 upx * Up to
(including)
3.95-1
运行在以下环境
系统 debian_9 upx * Up to
(including)
3.91-4
运行在以下环境
系统 fedora_29 upx * Up to
(excluding)
3.95-4.fc29
运行在以下环境
系统 fedora_30 upx * Up to
(excluding)
3.95-4.fc30
运行在以下环境
系统 fedora_EPEL_7 upx * Up to
(excluding)
3.95-4.el7
运行在以下环境
系统 opensuse_Leap_15.1 upx * Up to
(excluding)
3.96-lp151.3.3.1
阿里云评分
2.9
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-119 内存缓冲区边界内操作的限制不恰当
阿里云安全产品覆盖情况