低危 AdPlug 2.3.1具有基于堆的缓冲区溢出

CVE编号

CVE-2019-14692

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-08-07 02:15:00
漏洞描述
AdPlug 2.3.1在CmkjPlayer::load()中有一个基于堆的缓冲区溢出。
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
https://github.com/adplug/adplug
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 adplug_project adplug 2.3.1 -
2
运行在以下环境
系统 debian_9 adplug * Up to
(excluding)
2.2.1+dfsg3-0.4
3
运行在以下环境
系统 debian_sid adplug * Up to
(excluding)
2.3.3+dfsg-2
4
运行在以下环境
系统 debian_10 adplug * Up to
(excluding)
2.2.1+dfsg3-1
5
运行在以下环境
系统 debian_11 adplug * Up to
(excluding)
2.3.3+dfsg-2
6
运行在以下环境
系统 fedora_EPEL_7 adplug * Up to
(excluding)
2.3.3-1.el7
7
运行在以下环境
系统 fedora_EPEL_8 adplug * Up to
(excluding)
2.3.3-1.el8
8
运行在以下环境
系统 fedora_33 adplug * Up to
(excluding)
2.3.3-1.fc33
9
运行在以下环境
系统 fedora_32 adplug * Up to
(excluding)
2.3.3-1.fc32
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-787 跨界内存写
阿里云安全产品覆盖情况