低危 当使用非ASCII字符时,ADDC检查密码脚本不接收完整密码

CVE编号

CVE-2019-14833

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-11-06
漏洞描述
在Samba中发现了一个缺陷,所有版本从Samba4.5.0开始到Samba4.9.15、Samba4.10.10、Samba4.11.2,以处理用户密码更改或Samba用户新密码的方式。 Samba Active Directory Domain Controller可以配置为使用自定义脚本检查密码复杂性。 当密码中使用非ASCII字符时,此配置可能无法验证密码的复杂性,这可能导致为Samba用户设置弱口令,使其容易受到字典攻击。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 samba samba * From
(including)
4.10.0
Up to
(excluding)
4.10.10
运行在以下环境
应用 samba samba * From
(including)
4.11.0
Up to
(excluding)
4.11.2
运行在以下环境
应用 samba samba * From
(including)
4.5.0
Up to
(excluding)
4.9.15
运行在以下环境
系统 alpine_3.10 samba * Up to
(excluding)
4.10.10-r0
运行在以下环境
系统 alpine_3.11 samba * Up to
(excluding)
4.11.2-r0
运行在以下环境
系统 alpine_3.12 samba * Up to
(excluding)
4.11.2-r0
运行在以下环境
系统 alpine_3.13 samba * Up to
(excluding)
4.11.2-r0
运行在以下环境
系统 alpine_3.14 samba * Up to
(excluding)
4.11.2-r0
运行在以下环境
系统 alpine_3.15 samba * Up to
(excluding)
4.11.2-r0
运行在以下环境
系统 alpine_3.16 samba * Up to
(excluding)
4.11.2-r0
运行在以下环境
系统 alpine_3.17 samba * Up to
(excluding)
4.11.2-r0
运行在以下环境
系统 alpine_3.18 samba * Up to
(excluding)
4.11.2-r0
运行在以下环境
系统 alpine_3.19 samba * Up to
(excluding)
4.11.2-r0
运行在以下环境
系统 alpine_3.8 samba * Up to
(excluding)
4.8.12-r1
运行在以下环境
系统 alpine_3.9 samba * Up to
(excluding)
4.8.12-r1
运行在以下环境
系统 debian_10 samba * Up to
(excluding)
4.9.5+dfsg-5+deb10u4
运行在以下环境
系统 debian_11 samba * Up to
(excluding)
4.11.1+dfsg-2
运行在以下环境
系统 debian_12 samba * Up to
(excluding)
4.11.1+dfsg-2
运行在以下环境
系统 fedora_29 samba-test * Up to
(excluding)
4.9.15-0.fc29
运行在以下环境
系统 fedora_30 samba-test * Up to
(excluding)
4.10.10-0.fc30
运行在以下环境
系统 fedora_31 p * Up to
(excluding)
4.11.2-0.fc31
运行在以下环境
系统 opensuse_Leap_15.0 ctdb * Up to
(excluding)
4.7.11
运行在以下环境
系统 opensuse_Leap_15.1 ctdb * Up to
(excluding)
4.9.5
运行在以下环境
系统 suse_12_SP5 samba * Up to
(excluding)
4.10.17
运行在以下环境
系统 ubuntu_18.04 samba * Up to
(excluding)
4.7.6+dfsg~ubuntu-0ubuntu2.13
阿里云评分
2.7
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-305 使用基本弱点进行的认证绕过
CWE-521 弱口令要求
阿里云安全产品覆盖情况