低危 Ansible 日志信息泄露漏洞

CVE编号

CVE-2019-14846

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-10-09 08:15:00
漏洞描述
Ansible是美国Ansible公司的一款计算机系统配置管理器。该产品可用于发布、管理和编排计算机系统。
Ansible ansible_engine-2.x版本和ansible_engine-3.x版本至ansible_engine-3.5版本中存在日志信息泄露漏洞。该漏洞源于网络系统或产品的日志文件非正常输出。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible_engine * From
(including)
2.0
Up to
(including)
2.8.5
运行在以下环境
应用 redhat ansible_tower * From
(including)
3.0
Up to
(including)
3.5.3
2
运行在以下环境
系统 debian_10 ansible * Up to
(excluding)
2.7.7+dfsg-1
3
运行在以下环境
系统 debian_9 ansible * Up to
(excluding)
2.2.1.0-2+deb9u1
4
运行在以下环境
系统 debian_8 ansible * Up to
(excluding)
1.7.2+dfsg-2+deb8u2
5
运行在以下环境
系统 alpine_3.8 ansible * Up to
(excluding)
2.6.20-r0
6
运行在以下环境
系统 alpine_3.11 ansible * Up to
(excluding)
2.9.13-r0
7
运行在以下环境
系统 alpine_3.12 ansible * Up to
(excluding)
2.9.13-r0
8
运行在以下环境
系统 alpine_3.10 ansible * Up to
(excluding)
2.8.6-r0
9
运行在以下环境
系统 alpine_3.9 ansible * Up to
(excluding)
2.7.14-r0
10
运行在以下环境
系统 alpine_edge ansible * Up to
(excluding)
2.8.6-r0
11
运行在以下环境
系统 alpine_3.13 ansible * Up to
(excluding)
2.8.6-r0
12
运行在以下环境
系统 opensuse_Leap_15.1 ansible * Up to
(excluding)
2.9.6-lp151.2.7.1
阿里云评分
2.6
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    普通权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-117 日志输出的转义处理不恰当
CWE-532 通过日志文件的信息暴露
阿里云安全产品覆盖情况