低危 在签名中未验证DER编码

CVE编号

CVE-2019-14859

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-01-03
漏洞描述
在0.13.3之前的所有python-ecdsa版本中都发现了一个漏洞,它没有正确地验证签名是否使用DER编码。如果没有这种验证,则可以接受格式错误的签名,从而使签名具有延展性。如果没有适当的验证,攻击者就可以使用可塑签名来创建错误的事务。
解决建议
建议您更新当前系统或软件至最新版,完成漏洞的修复。
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 python-ecdsa_project python-ecdsa * Up to
(excluding)
0.13.3
运行在以下环境
应用 redhat ceph_storage 2.0 -
运行在以下环境
应用 redhat ceph_storage 3.0 -
运行在以下环境
应用 redhat openstack 10 -
运行在以下环境
应用 redhat openstack 13.0 -
运行在以下环境
应用 redhat openstack 14.0 -
运行在以下环境
应用 redhat openstack 15.0 -
运行在以下环境
应用 redhat virtualization 4.0 -
运行在以下环境
系统 alpine_3.11 py3-ecdsa * Up to
(excluding)
0.13.3-r0
运行在以下环境
系统 alpine_3.12 py3-ecdsa * Up to
(excluding)
0.13.3-r0
运行在以下环境
系统 alpine_3.13 py3-ecdsa * Up to
(excluding)
0.13.3-r0
运行在以下环境
系统 alpine_3.14 py3-ecdsa * Up to
(excluding)
0.13.3-r0
运行在以下环境
系统 alpine_3.15 py3-ecdsa * Up to
(excluding)
0.13.3-r0
运行在以下环境
系统 alpine_3.16 py3-ecdsa * Up to
(excluding)
0.13.3-r0
运行在以下环境
系统 alpine_edge py3-ecdsa * Up to
(excluding)
0.13.3-r0
运行在以下环境
系统 debian_10 py3-ecdsa * Up to
(excluding)
0.13-3+deb10u1
运行在以下环境
系统 debian_8 py3-ecdsa * Up to
(excluding)
0.11-1+deb8u1
运行在以下环境
系统 debian_9 py3-ecdsa * Up to
(excluding)
0.13-2+deb9u1
运行在以下环境
系统 fedora_EPEL_7 py3-ecdsa * Up to
(excluding)
0.13.3-1.el7
运行在以下环境
系统 opensuse_Leap_15.0 py3-ecdsa * Up to
(excluding)
0.13.3-lp150.2.3.1
运行在以下环境
系统 opensuse_Leap_15.1 py3-ecdsa * Up to
(excluding)
0.13.3-lp151.3.3.1
运行在以下环境
系统 suse_12 python-ecdsa * Up to
(excluding)
0.13.3-5.10
运行在以下环境
系统 ubuntu_16.04 py3-ecdsa * Up to
(excluding)
0.13-2ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_16.04.7_lts python-ecdsa * Up to
(excluding)
0.13-2ubuntu0.16.04.1
运行在以下环境
系统 ubuntu_18.04 py3-ecdsa * Up to
(excluding)
0.13-2ubuntu0.18.04.1
运行在以下环境
系统 ubuntu_18.04.5_lts python-ecdsa * Up to
(excluding)
0.13-2ubuntu0.18.04.1
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-347 密码学签名的验证不恰当
阿里云安全产品覆盖情况