Visual Studio Live Share 欺骗漏洞

CVE编号

CVE-2019-1486

利用情况

暂无

补丁情况

N/A

披露时间

2019-12-10
漏洞描述
Microsoft Visual Studio Live Share中存在欺骗漏洞。攻击者可利用该漏洞执行未授权的操作。以下产品及版本受到影响:Microsoft Visual Studio 2019 16.0版本,Visual Studio 2019 16.0版本至16.4版本,Visual Studio Live Share extension。

解决建议
用户可参考如下厂商提供的安全补丁以修复该漏洞:
https://portal.msrc.microsoft.com/zh-CN/security-guidance/advisory/CVE-2019-1486
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 microsoft visual_studio_2019 * From
(including)
16.0
Up to
(including)
16.4
运行在以下环境
应用 microsoft visual_studio_live_share * Up to
(excluding)
1.0.1374
运行在以下环境
系统 alibaba_cloud_linux_2.1903 ksh * Up to
(excluding)
20120801-140.1.al7
运行在以下环境
系统 alpine_3.10 ksh * Up to
(excluding)
4.10.11-r0
运行在以下环境
系统 alpine_3.11 ksh * Up to
(excluding)
2.13-r0
运行在以下环境
系统 alpine_3.12 ksh * Up to
(excluding)
2.13-r0
运行在以下环境
系统 alpine_3.13 ksh * Up to
(excluding)
2.13-r0
运行在以下环境
系统 alpine_3.9 ksh * Up to
(excluding)
2.7.16-r0
运行在以下环境
系统 alpine_edge ksh * Up to
(excluding)
2.13-r0
运行在以下环境
系统 amazon_2 ksh * Up to
(excluding)
4.6.5-11.amzn2.4.7
运行在以下环境
系统 centos_6 ksh * Up to
(excluding)
20120801-38.el6_10
运行在以下环境
系统 centos_7 ksh * Up to
(excluding)
20120801-140.el7_7
运行在以下环境
系统 debian_10 ksh * Up to
(excluding)
3.4.2-2+deb10u1
运行在以下环境
系统 debian_8 ksh * Up to
(excluding)
9.06~dfsg-2+deb8u5
运行在以下环境
系统 debian_9 ksh * Up to
(excluding)
9.26a~dfsg-0+deb9u6
运行在以下环境
系统 fedora_29 ksh * Up to
(excluding)
9.27-2.fc29
运行在以下环境
系统 fedora_30 ksh * Up to
(excluding)
2020.0.0-2.fc30
运行在以下环境
系统 fedora_31 ksh * Up to
(excluding)
2020.0.0-2.fc31
运行在以下环境
系统 opensuse_Leap_15.0 ksh * Up to
(excluding)
2.12-lp150.2.3.1
运行在以下环境
系统 opensuse_Leap_15.1 ksh * Up to
(excluding)
2.12-lp151.3.3.1
运行在以下环境
系统 oracle_6 ksh * Up to
(excluding)
20120801-38.el6_10
运行在以下环境
系统 oracle_7 ksh * Up to
(excluding)
20120801-140.0.1.el7_7
运行在以下环境
系统 oracle_8 ksh * Up to
(excluding)
20120801-253.0.1.el8_1
运行在以下环境
系统 redhat_6 ksh * Up to
(excluding)
0:20120801-38.el6_10
运行在以下环境
系统 redhat_7 ghostscript * Up to
(excluding)
0:9.25-2.el7_7.3
运行在以下环境
系统 suse_12 ghostscript * Up to
(excluding)
9.27-23.31
运行在以下环境
系统 suse_12_SP4 ksh * Up to
(excluding)
2.11-36.6.1
运行在以下环境
系统 suse_12_SP5 ksh * Up to
(excluding)
2.11-36.6.1
运行在以下环境
系统 ubuntu_16.04.7_lts cpio * Up to
(excluding)
2.11+dfsg-5ubuntu1.1
运行在以下环境
系统 ubuntu_18.04.5_lts angular.js * Up to
(excluding)
1.5.10-1
CVSS3评分
6.1
  • 攻击路径
    网络
  • 攻击复杂度
  • 权限要求
  • 影响范围
    已更改
  • 用户交互
    需要
  • 可用性
  • 保密性
  • 完整性
CWE-ID 漏洞类型
CWE-601 指向未可信站点的URL重定向(开放重定向)
阿里云安全产品覆盖情况