中危 angular 跨站脚本漏洞

CVE编号

CVE-2019-14863

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-01-03
漏洞描述
AngularJS是一款基于TypeScript的开源Web应用程序框架。
angular 1.5.0-beta.0之前版本中存在跨站脚本漏洞。该漏洞源于WEB应用缺少对客户端数据的正确验证。攻击者可利用该漏洞执行客户端代码。

解决建议
厂商已发布了漏洞修复程序,请及时关注更新:
https://github.com/angular/angular.js/commit/f33ce173c90736e349cf594df717ae3ee41e0f7a
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 angularjs angular.js * From
(including)
1.0.0
Up to
(including)
1.4.14
运行在以下环境
应用 redhat decision_manager 7.0 -
运行在以下环境
应用 redhat process_automation 7.0 -
运行在以下环境
系统 debian_8 angular.js * Up to
(excluding)
1.2.26-1+deb8u1
运行在以下环境
系统 ubuntu_18.04 angular.js * Up to
(excluding)
1.5.10-1
运行在以下环境
系统 ubuntu_18.04.5_lts angular.js * Up to
(excluding)
1.5.10-1
运行在以下环境
系统 ubuntu_18.04_lts angular.js * Up to
(excluding)
1.5.10-1
阿里云评分
4.9
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    越权影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-79 在Web页面生成时对输入的转义处理不恰当(跨站脚本)
阿里云安全产品覆盖情况