低危 由于错误使用ber_scanf()导致IPA服务器拒绝服务

CVE编号

CVE-2019-14867

利用情况

暂无

补丁情况

官方补丁

披露时间

2019-11-27
漏洞描述
在IPA中发现了一个缺陷,该缺陷在4.6.7之前的所有4.6.x版本,4.7.4之前的所有4.7.x版本以及4.8.3之前的所有4.8.x版本中,在IPA服务器的一些组件中使用了内部函数ber_scanf(),分析了Kerberos关键数据。 未经身份验证的攻击者可能触发对krb主密钥的解析,可能导致IPA服务器崩溃或在某些情况下,导致在托管IPA服务器的服务器上执行任意代码。
解决建议
目前厂商尚未提供相关漏洞修补方案,请关注厂商主页及时更新:
https://www.freeipa.org
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 freeipa freeipa * From
(including)
4.6.0
Up to
(excluding)
4.6.7
运行在以下环境
应用 freeipa freeipa * From
(including)
4.7.0
Up to
(excluding)
4.7.4
运行在以下环境
应用 freeipa freeipa * From
(including)
4.8.0
Up to
(excluding)
4.8.3
运行在以下环境
系统 amazon_2 ipa * Up to
(excluding)
4.6.5-11.amzn2.4.7
运行在以下环境
系统 debian_10 ipa * Up to
(including)
4.7.2-3
运行在以下环境
系统 fedora_29 ipa * Up to
(excluding)
4.7.4-1.fc29
运行在以下环境
系统 fedora_30 ipa * Up to
(excluding)
4.8.3-1.fc30
运行在以下环境
系统 fedora_31 ipa * Up to
(excluding)
4.8.3-1.fc31
运行在以下环境
系统 oracle_7 ipa * Up to
(excluding)
4.6.5-11.0.1.el7_7.4
运行在以下环境
系统 redhat_7 ipa-client * Up to
(excluding)
0:4.6.5-11.el7_7.4
阿里云评分
3.1
  • 攻击路径
    远程
  • 攻击复杂度
    复杂
  • 权限要求
    无需权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-400 未加控制的资源消耗(资源穷尽)
CWE-94 对生成代码的控制不恰当(代码注入)
阿里云安全产品覆盖情况