低危 恶意代码可以在nxos_file_copy模块中生成文件名

CVE编号

CVE-2019-14905

利用情况

暂无

补丁情况

官方补丁

披露时间

2020-04-01 06:15:00
漏洞描述
在2.9.3之前的2.9.x版本,2.8.8之前的2.8.x版本,2.7.16之前的2.7.x版本及更早版本中发现了一个漏洞,其中Ansible的nxos_file_copy模块可用于将文件复制到闪存或引导闪存中。在NXOS设备上。恶意代码可能伪造filename参数来执行OS命令注入。除其他问题外,这可能导致系统机密性丧失。
解决建议
目前厂商暂未发布修复措施解决此安全问题,建议使用此软件的用户随时关注厂商主页或参考网址以获取解决办法:
https://www.ansible.com/
受影响软件情况
# 类型 厂商 产品 版本 影响面
1
运行在以下环境
应用 redhat ansible_engine * From
(including)
2.7.0
Up to
(excluding)
2.7.16
运行在以下环境
应用 redhat ansible_engine * From
(including)
2.8.0
Up to
(excluding)
2.8.8
运行在以下环境
应用 redhat ansible_engine * From
(including)
2.9.0
Up to
(excluding)
2.9.3
2
运行在以下环境
应用 redhat ansible_tower 3.0.0 -
运行在以下环境
应用 redhat ceph_storage 3.0 -
运行在以下环境
应用 redhat cloudforms_management_engine 5.0 -
运行在以下环境
应用 redhat openstack 13.0 -
3
运行在以下环境
系统 debian_10 ansible * Up to
(excluding)
2.7.7+dfsg-1+deb10u1
4
运行在以下环境
系统 debian_9 ansible * Up to
(excluding)
2.2.1.0-2+deb9u1
5
运行在以下环境
系统 alpine_3.11 ansible * Up to
(excluding)
2.9.3-r0
6
运行在以下环境
系统 alpine_3.10 ansible * Up to
(excluding)
2.8.8-r0
7
运行在以下环境
系统 alpine_3.12 ansible * Up to
(excluding)
2.9.3-r0
8
运行在以下环境
系统 alpine_3.9 ansible * Up to
(excluding)
2.7.16-r0
9
运行在以下环境
系统 alpine_edge ansible * Up to
(excluding)
2.9.3-r0
10
运行在以下环境
系统 alpine_3.13 ansible * Up to
(excluding)
2.9.3-r0
11
运行在以下环境
系统 fedora_31 ansible * Up to
(excluding)
2.9.3-1.fc31
12
运行在以下环境
系统 fedora_EPEL_8 ansible * Up to
(excluding)
2.9.3-1.el8
13
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.9.3-1.el7
14
运行在以下环境
系统 fedora_30 ansible * Up to
(excluding)
2.9.3-1.fc30
15
运行在以下环境
系统 opensuse_Leap_15.1 ansible * Up to
(excluding)
2.9.6-lp151.2.7.1
16
运行在以下环境
系统 fedora_EPEL_8 ansible * Up to
(excluding)
2.9.3-1.el8
17
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.9.3-1.el7
18
运行在以下环境
系统 opensuse_Leap_15.1 ansible * Up to
(excluding)
2.9.6-lp151.2.7.1
19
运行在以下环境
系统 alpine_3.14 ansible * Up to
(excluding)
2.9.3-r0
20
运行在以下环境
系统 fedora_EPEL_8 ansible * Up to
(excluding)
2.9.3-1.el8
21
运行在以下环境
系统 fedora_EPEL_7 ansible * Up to
(excluding)
2.9.3-1.el7
22
运行在以下环境
系统 opensuse_Leap_15.1 ansible * Up to
(excluding)
2.9.6-lp151.2.7.1
阿里云评分
1.7
  • 攻击路径
    本地
  • 攻击复杂度
    复杂
  • 权限要求
    管控权限
  • 影响范围
    有限影响
  • EXP成熟度
    未验证
  • 补丁情况
    官方补丁
  • 数据保密性
    无影响
  • 数据完整性
    无影响
  • 服务器危害
    无影响
  • 全网数量
    100
CWE-ID 漏洞类型
CWE-610 资源在另一范围的外部可控制索引
阿里云安全产品覆盖情况